1

I have a set of civirules in places, when a contact is tagged it should send a welcome email. But I am keep receiving the following error message in log and welcome email is not sent. It happens for new & existing contacts. Anyone has a clue what is it? How to fix it please? Thanks.

Log in Drupal:

Civirules api action exception: Mandatory key(s) missing from params array: source_contact_id. API call: Email.send with params: from_name="Email from", from_email="abc@example.com", template_id="108", location_type_id="1", alternative_receiver_address="test@me.com", cc="", bcc="", file_on_case="", contact_id="8949", extra_data="Array"

Log in Civirules Logger:

    Array
(
    [line] => 77
    [file] => /home/webadmin/public_html/cmm/sites/default/files/civicrm/ext/org.civicoop.civirules-master/CRM/CivirulesActions/Generic/Api.php
    [exception_message] => Civirules api action exception: Error sending e-mail to Katie Lost  . API call: Email.send with params: from_name="from name", from_email="abc@example.com", template_id="108", location_type_id="", alternative_receiver_address="", cc="", bcc="", file_on_case="", contact_id="9688", extra_data="Array"
    [rule_title] => Welcome Emails Workflow
    [original_error] => Error on {file} (Line {line})

{exception_message}
    [reason] => Failed to execute rule
)

enter image description here

  • Hi. I tried this and works on my test sites. Can you usually send anything from the 'from' email address you are using for the rule? – RebeccaTregenna May 4 at 13:35
  • Seems it’s an issue with msgtemplateblocker extension – Tapash May 4 at 15:45
1

Can you try after applying patch from here may or may not be related!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.