I am trying to use the Drupal 8 Project on GitLab and I am having an issue with a downstream CiviCRM requirement. I am not sure where to post this issue, so I hope it is okay if I post it here.

The Composer files download civicrm/civicrm-asset-plugin. This asset includes pear/net_smtp. There is also a patch CiviCRM custom error message for CRM-8744.

When Composer attempts to apply the patch, I get the error " Cannot apply patch Add in CiviCRM custom error message for CRM-8744 (https://raw.githubusercontent.com/civicrm/civicrm-core/a6a0ff13d2a155ad962529595dceaef728116f 96/tools/scripts/composer/patches/net-smtp-patch.patch)!".

I am not sure how to change what files are included in civicrm/civicrm-asset-plugin if there should be another patch or how to try and skip the patch in Composer.

Any help is greatly appreciated.

Thanks, Steve

  • I followed this process and am having a problem where the CiviCRM menu is missing. It looks like the underlying pages may be working if you add the url manually but the menu is not there.
    – HeneryH
    Jul 11, 2020 at 16:20

1 Answer 1


Roundearth just recently switched to using civicrm-asset-plugin and it may not be fully integrated yet.

CiviCRM can be installed on drupal 8 without roundearth now - it's still not "official" but is being used by some.

composer create-project drupal/recommended-project some-folder

cd some-folder

# replace the 'x' below with a proper version number

composer require civicrm/civicrm-core:5.x.x civicrm/civicrm-packages:5.x.x civicrm/civicrm-drupal-8:5.x.x civicrm/civicrm-asset-plugin:~1.0.1

Install Drupal as usual

Then to install CiviCRM - make sure the civicrm.settings.php file can be created -> by making the web/sites/default directory writeable:

chmod +w web/sites/default

Then you can either go to Extend and enable CiviCRM Core or you can do this from the command line:

drush en -y civicrm

  • Don't forget to follow that with: :-) composer require 'drupal/webform_civicrm:^5.0' May 7, 2020 at 15:39
  • He he. That's one way to pad extension usage stats! If you're going to use drush for the rest of the install though then you need to composer require drush/drush:^8 I think. It didn't work with 9 or 10 the last time I tried but that was a while ago. There are official docs coming, just they aren't up yet.
    – Demerit
    May 7, 2020 at 15:48
  • I always use whatever Tim decides we should use: which drush -> /Applications/MAMP/htdocs/buildkit/bin/drush May 7, 2020 at 16:00
  • He he. Buildkit is using drush8, but also if you have buildkit installed then you only need one command to do the whole thing: civibuild create somename --type d8rec-clean
    – Demerit
    May 7, 2020 at 20:33
  • No don’t want to do that! That’s too easy :-) May 7, 2020 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.