0

I am trying to setup Gsuite as bounce processing for CiviCRM using this guide https://civicrm.org/blog/dahndy/leveraging-civicrm-email-to-activity-processing-in-gmail

But keep getting the following message when schedule job is ran. Any idea how to fix it please?

One thing in the log, it says "[email protected]" but it should have said "[email protected]" as per my sessings below, is that right?

Parameters parsed (and passed to API method): 
a:1:{s:7:"version";i:3;}

Full message: 
Finished execution of Fetch Bounces with result: Failure, Error message: Could not connect to MailStore for [email protected]
Error message: 

An error occured while sending or receiving mail. Failed to connect to the server: imap.gmail.com:993.

enter image description here

3

1 Answer 1

5

So I just ran into a similar issue. Our bounce handling stopped a few months ago and nobody noticed. We also use GSuite, and our email address appears in a similar fashion in the log. I thought it looked strange at first too, but since we changed nothing and it went from working to not working, I knew that wasn't the issue. I also tried changing the email account password to see if that would fix the problem.

It turned out that Google turned off access for less secure apps automatically, effectively blocking access to the return email account from CiviCRM. As soon as I toggled that switch, bounce handling started working again. This is the link that worked to turn it back on: https://myaccount.google.com/u/5/lesssecureapps?hl=en

3
  • Would you mind sharing your bounced processing settings from civi and gmail please? I have app specific password instead of less secure apps.
    – Tapash
    Dec 19, 2020 at 18:08
  • It's been a really long time since we set this up, but I followed the instructions in the CiviMail documentation found here: docs.civicrm.org/sysadmin/en/latest/setup/civimail/…
    – LMK Web
    Dec 30, 2020 at 17:25
  • From May 30, 2022, ​​Google no longer supports the use of third-party apps or devices which ask you to sign in to your Google Account using only your username and password. Jan 19, 2023 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.