1

A long while ago, you could save reports as dashlet.

On the latest version of civi (both clean installs and upgrades), the report still has the option "Available for Dashboard?" but it doesn't seem to have any effect, or any way to save as a new report/dashlet (my memory is a bit unclear on how it worked in the past)

Am I missing something obvious or has that feature gone missing?

3

It's working fine on 5.25.0 for me.

EDIT: You must go to Access tab > enable Available for Dashboard > select actions drop down > select Save. (Not view results).

That appears to be the misstep. Clicking View Results does not save the report. There is valid reason for having the save v. view results functionality as there is the permission save report criteria. Sometimes you may want someone to access and modify the report for one time use but not save it for everyone.

Then On CiviCRM Home, you have to click Configure Your Dashboard and drag it into dashlet area.

| improve this answer | |
  • Sorry, wasn't clear: it's the creating dashlets part that has a problem on my side, adding them on the dashboard works fine – Xavier May 20 at 4:49
  • I can't replicate – Andy Burns May 20 at 11:58
  • Can you create a new report, check "Available for dashboard" and get it as a new available dashlet for your dashboard? Could you tell me the CMS you are using? – Xavier May 20 at 16:33
  • I had an existing report and made it available for dashboard. I can try creating a new report later. WP. – Andy Burns May 20 at 18:05
  • @Xavier I'm on Civi 5.25 and Drupal 7 and it's working for me. – Joe McLaughlin May 21 at 2:46
1

I am experiencing the same issues. I've tried it on two client sites after another client reported the issue on their site with the same result. I also tried it on this demo site: https://demo.circle-interactive.co.uk. These are 5.24.x sites. Since two people reported they were able to generate new dashlets using 5.25.0, I updated one of the sites to see if this would solve the issue. It did not.

  1. Choose a report that does not have a dashlet already. Contribution Report - Top Donors.
  2. On the Top Donors >> Access tab, I enable Add to My Reports and Available for Dashboard and Refresh Results.
  3. Under Reports >> My Reports, Top Donor is not shown. Nor is it shown as a dashlet when I view Configure Your Dashboard.

What I did discover, is that the values for Add to My Reports, Available for Dashboard, Limit Dashboard Results and Cache dashlet for are not being saved. (I've tried this in two browsers: Chrome and Firefox updated to the latest versions.)

  1. Load a report and view the Access tab.
  2. Update values for Add to My Reports, Available for Dashboard, Limit Dashboard Results and Cache dashlet for fields and click Refresh Results/View Results.
  3. Return to the Access tab for the same report and verify that the values are what you set in step 2.
  4. Load a different Civi page (such as Reoprt Listing)
  5. Return to the Access tab for the report where you set you new values. In my case they have reverted to my original values. And no dashlet/no my reports.

What's also strange is that I thought that using the browser's Developer Tool reload option Empty Cache and Hard Reload would revert the values; but it did not. It seems that this only happens when I load a new Civi page and then return to the Access tab of the report.

| improve this answer | |
  • I've opened an issue for this lab.civicrm.org/dev/core/-/issues/1786 – Charlotta Beavers May 28 at 18:56
  • This might clear up the confusion for some. The issue I had was that I didn't realize that I needed to use the Save button to save the updates (since based on the UI, it did not seem related to what I was doing). I hope this helps someone else. – Charlotta Beavers Jul 2 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.