Is there a way to not send an email when Webform CiviCRM creates an activity?

I want to create an activity for admin purposes but not that the new member receives an email.

I don't see an option to prevent this?

Any ideas?

enter image description here

  • does respective webform has email send enabled? – Pradeep Nayak May 22 at 18:21
  • yes it sends confirmation email. – Guillaume Sorel May 25 at 8:21

Yes (I think this should work for an Activity created via a webform as well?) - go to Administer -> Customize Data and Screens -> Display Preferences

enter image description here


and see

"Do not notify assignees for" and select the Activities to exclude.

"These activity types will be excluded from automated email notifications to assignees."

It's odd that it is under Display Preferences IMHO, but there it is.

UPDATE: Just want to point folks to Peter's and Karin's answers as well. So, depending on your use case, you may want to have the email not be sent either through an Activity created via your particular webform, or, through the Civi settings. My answer will apply to all activities that you have selected, which you may not want.

| improve this answer | |
  • Yes that's correct -> and yes that will stop CiviCRM from emailing Assignees for Activities generated with webform civicrm module as well. – KarinG - Semper IT May 22 at 21:28
  • Yes thanks @KarinG-SemperIT and Pete, I updated my answer above. – Joe McLaughlin May 22 at 22:14
  • 👍 Glad you remembered this setting lives under Display Preferences - I only remembered it lived somewhere where I would likely not find it again. – KarinG - Semper IT May 23 at 0:54
  • many thanks Joe, I could have searched a long time for it! Display preferences is not so obvious but at least I can set this parameter. Because I created a custom activity type, disabling only this activity should not affect CiviCRM. – Guillaume Sorel May 25 at 8:19
  • @GuillaumeSorel you're welcome! – Joe McLaughlin May 25 at 21:33

CiviCRM Core will (by default) send out an E-mail to Contacts who are assigned to an Activity.

You can change this setting to Not send out any E-mail to Contacts who are assigned to an Activity and handle Email notifications on a per webform level. If you need an example of that - let me know.

Here is an example: On the form: E-mail + a checkbox (without label:   and text: Send E-mail Notification:

enter image description here

Conditionals -> if the checkbox is checked -> show the E-mail field:

enter image description here

In Webform -> E-mails -> send E-mail to Component -> E-mail:

enter image description here

Of course you can make this as complicated as you want (also e.g. by including Activity Status and/or Activity Type in the Conditionals.

| improve this answer | |
  • I would be pretty curious to know how to set this from within webform, maybe it could be useful under certain circumstances. – Guillaume Sorel May 25 at 8:20
  • Added some screenshots - above^^ – KarinG - Semper IT May 25 at 13:35
  • thanks Karin! very sweet. – Guillaume Sorel May 25 at 16:05
  • Thank you @KarinG-SemperIT! – Joe McLaughlin May 25 at 21:32

You can specify which Types of Activities send emails via CiviCRM but setting it will affect Activities created both in CiviCRM directly and via webforms.

I can flesh this out if this solution would work.

| improve this answer | |
  • Joe's answer fleshes out where the setting for this is. – petednz - fuzion May 24 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.