I'm using CiviCRM 4.6.4 on Joomla 2.5.17. I'm new to Mailings so there may be something I am doing wrong, but there are several things that don't seem to work, including selecting a Group, sending an email to an address as well as to a Group. But, let me first ask about selecting a Group.

I created the Group "test" with two contacts with valid email addresses and marked the group for Mailing. The group appears in the Recipients drop down, but when I select the group, I receive an indication of "No recipients" and then the Recipients field label is highlighted in Red. What could I be doing wrong? Is this a known issue?

I primarily use Chrome, but I have tried in Firefox and Safari and get the same result, so I'm thinking that there is something misconfigured in a database setting, Javascript file or PHP file, but I wouldn't know where to look to debug. I have noticed there have been several postings regarding CiviMail and 4.6.x especially from Joomla or Wordpress users, so I don't know if someone has diagnosed this particular issue or if I am simply doing something wrong on my end.

I should also mention that I have upgraded from 4.4.x to 4.5.x over time and then recently to 4.6.2 and now 4.6.4, so I don't know if any of those upgrades broke my CiviMail configuration somehow.

Drupal 6

  • Can you check in your console what ajax calls are being fired? Specifically the one that is fired just as you see "no recipients" pop up... what's coming back from the server exactly?
    – Coleman
    Commented Jun 29, 2015 at 0:54
  • 1
    Do your test contacts have on hold, do not email or bulk opt out set? Are their email addresses primary (they should be if they only have one each)? Is the group smart?
    – DaveFF
    Commented Jun 30, 2015 at 8:52
  • If you're still seeing this issue, you might want to reach out to the author of civicrm.stackexchange.com/questions/5182/… and see if you can share resources / collab on a fix. Probably worth reporting to JIRA also. Commented Sep 9, 2015 at 20:14
  • Also, welcome to StackExchange & thanks for posting your question! When you do, it's helpful to future viewers if you report back - "problem went away", "I fixed it myself with this one easy configuration", "that's it, I give up, I'm moving to Alaska". By doing that, we all benefit from the tool. Commented Sep 9, 2015 at 20:18

1 Answer 1


I had a similar problem and went to: "Administer" -> "System Settings" -> "Cleanup Caches and Update Paths" and then ran "Cleanup Caches". When I went back to the mailing all my groups appeared again.

  • What CMS? I ask because we have had one out of fifty sites throw up this problem. Your solution worked. Yay. Thanks. The odd thing about this 'one' is that it is WP while our others are all Drupal - so am wondering if this is CMS related.
    – petednz - fuzion
    Commented Nov 16, 2017 at 1:32
  • This was for a Drupal 6 installation Commented Nov 17, 2017 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.