1

When I set up a url path alias in Drupal for a civievent (eg. pubquiz rather than civicrm/event/info&reset=1&id=33) and try to access the alias I get the message 'Access denied You are not authorized to access this page' when I try to access it. This only affects the alias, not the raw civevent path offered by Civi and used in the alias setup.

This approach has worked perfectly in the past, but hasn't been used for six months or so. Other aliases for native drupal paths work perfectly.

When I look at the list of url links in Drupal, I see that for Civievents the 'alias' link looks fine but the 'system' link is munged. It displays as 'civicrm/event/info&reset=1&id=33' but the actual link is https://XXXX.org/?q=civicrm/event/info%26reset%3D1%26id%3D33

A recent change in Drupal 7 ?

I can work a round this in Webforms, but this way was easier for simple events.

Drupal 7.7.1/Civi 5.24.3

1

This is still working for me using redirects

admin/config/search/redirect

sends

/join

to

/civicrm/contribute/transact?reset=1&id=3

| improve this answer | |
  • Thanks. This D7 was not configured with the Redirect module, only admin/config/search/aliases. I'm not clear about alias vs redirect usage cases. Anyway, when I added the Redirect module it produced the same result with munged/encoded special characters in the Civi URL. When I looked at another D7 site I administer, it did have the Redirect module already and the Civi links in it are clean and work just fine! There must me something distinctive about this D7 installation (a module?) that's causing this that I'll try to find via elimination. – Bryan Jun 9 at 4:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.