0

So we have historic records which have been imported which include start dates going back to 1990s.

However, when those records are brought up for editing, the minDate kicks in and sets the date to 20 years ago.

I would like to be able disable the minDate test altogether, but cannot find it in the form setups at all.

If I can't disable it, can I set it to something much older?

Any suggestions as to where I should be looking, can't find anything in membership.php or .tpl that seems to set this.

3

minDate for these entities can be updated at Administer > Customize Data and Screens > Date Preferences, i.e, civicrm/admin/setting/preferences/date?action=reset=1

enter image description here

Click on Edit and update the Start Offset(minDate) to eg 30. This will default the membership start date to start from current year - 30.

enter image description here

| improve this answer | |
  • Of course it is!!! Thanks – Simon Walden Jun 18 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.