0

Running Drupal 7.69 / CiviCRM 5.25.0 / PHP 7.3 After upgrading some Modules : Webform, Views Bulk Operations, i18n, and Content Access,

Emails Tokens ([submission:completed_date:long], [submission:user], [submission:values], [submission:url]) are not populated in received mails.

And those usual tokens are not shown when browsing "available tokens" in the Webform Email Template Setting.

I have asked the question on the Drupal SackExchange, but my notation there is too low to get an answer.

Any help is welcome.

  • i would try replicating this as a pure Drupal webform - do not use civicrm on the form. then you will be able to confirm whether this is pure Drupal issue or not. – petednz - fuzion Jul 2 at 20:29
  • For sure it is. Is token module still enabled? – KarinG - Semper IT Jul 2 at 22:15
2

Thank you to both of you (Karin and Pete) for your suggestions : I have solved the problem.

I have disabled Token and Entity Tokens Modules (and requested associated Modules)

... then reactivated :

The probem comes from the Advanced User Management Module : when it is enabled, most of the tokens cannot be browsed (among which the default proposed ones in the mail content).

I will post this answer on the Drupal StackExchange.

| improve this answer | |
0

Submitter [submission:user] def. shows for me in available tokens

Drupal core 7.72

Webform 7.x-4.21

Webform Tokens 7.x-4.0

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.