1

I have a fresh install of CiviCRM (5.27) running on a Google Cloud Server Debian buster.

System is fully updated WordPress is 5.4.2

I wish to use Geocoding and of course noticed it is not in the searchable list of extensions.

I went to the download page and see that it says 5.26 - the documentation here leads me to believe that means "at least 5.26" so 5.27 should (in my mind - and correct me if I am wrong) be ok.

I put the zip file in the ext directory and changed the ownership to www-data:www-data and unzipped.

I refreshed extensions loader and saw it there and pressed install and then got a blank screen (civicrm themed so not a WP error) saying my wordpress install had a critical error.

Refreshing the page still shows the option to install and everything else works.

I hope I have given sufficient detail and am prepared to do any level of debugging.

I did not wish to try anything in case anyone wishes to see this error pristine (I did try install one second time).

Thank you,

Karl

PS, here is an error log entry:

[Tue Jul 07 00:57:43.003646 2020] [php7:error] [pid 26414] [client 107.143.245.58:56972] PHP Fatal error: require( ): Failed opening required '/var/www/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/ext/org.wikimedia.geocode r-1.4/vendor/composer/../symfony/polyfill-mbstring/bootstrap.php' (include_path='.:/var/www/html/civiwalk.com/wp-co ntent/plugins/civicrm/civicrm:/var/www/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/packages:/var/www/html/ civiwalk.com/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom:/var/www/html/civiwalk.com/wp-content/plugins/civ icrm/civicrm/vendor/phpseclib/phpseclib/phpseclib:/var/www/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/ven dor/pear/pear_exception:/var/www/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/vendor/pear/auth_sasl:/var/ww w/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/vendor/pear/log:/var/www/html/civiwalk.com/wp-content/plugin s/civicrm/civicrm/vendor/pear/console_getopt:/var/www/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/vendor/p ear/pear-core-minimal/src:/var/www/html/civiwalk.com/wp-content/plugins/civicrm/civicrm/vendor/p in /var/www/html/c iviwalk.com/wp-content/plugins/civicrm/civicrm/ext/org.wikimedia.geocoder-1.4/vendor/composer/autoload_real.php on line 66, referer: http://www.civicafe.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fextensions&action=add &id=org.wikimedia.geocoder&key=org.wikimedia.geocoder

2

It sounds like an incomplete install. You might need to run composer install from inside the ext/org.wikimedia.geocode folder.

But you don't need the extension if you just want to use basic geocoding in civicrm, you just need to set it up at administer - system settings - mapping and geocoding. The extension just adds more features.

UPDATE: It seems like the download version of the extension was an incomplete install. A new version is now available.

3
  • I am about to go to work, so it will be later tonight but I will try that and I did not know that geocoding is in the core now. Thank you! – Karl Tatgenhorst Jul 7 '20 at 9:32
  • Thanks for the suggestion, composer says nothing to install or update. Sorry, was unable to get home in time last night to try. – Karl Tatgenhorst Jul 8 '20 at 23:14
  • Would still like to use this plugin as it seems to be more extensible for data searching and collection, but I have configured it in the core package. Thank you, Demerit for getting me so much further along. – Karl Tatgenhorst Jul 8 '20 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.