0

Drupal 7.72 Civi 5.24.5

I recently added an IF statement to our receipts and Thank-You letters to comply with Florida Charity Regulations. The state of FL requires us to have a statement on our receipts for donors from FL. So I did a IF 'FL' then... It works with the System Workflow Templates for online and offline receipts. However, for checks we send a Thank-You Letter as a receipt. That kinda works. The difference I see is, the Thank-You letter has a WYSIWYG with it but the System Workflow Template online/offline does not. The WYSIWYG shows {if $stateProv eq 'FL'} but the html source has {if $stateProv eq & #39;FL& #39;} (I added spaces so it displays without converting to ')  If I change the html source to {if $stateProv eq 'FL'} it works but even though we check "Update Template" it still needs to have this changed every time we use the Thank-You letter template.

  1. How do I fix the Thank-You letter?
  2. Where do I find the WYSIWYG settings in CiviCRM? I tried to find where to disable that or even find what WYSIWYG we are using so I could Google a fix to make '' stick.
2

You can turn off html encoding for CKeditor through UI

Navigate to Administer >> Customize Data and Screens >> Display preferences

Scroll down until you see Configure CkEditor button. Click on it to view all the settings. Under Advance options add entities option as False(as shown in image) and save the form.

enter image description here

Note: You will need to clear your browser cache to reflect the changes(and CiviCRM caches).

If you want to turn off the ck-editor completely for whole site than you can switch to text area. You need to navigate it to CiviCRM >> Administer >> Customize Data and Screens >> Display preferences. Change value for Wysiwig Editor from ckeditor to text area.

HTH

Pradeep

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.