1

Wordpress 5.4.2, CiviCRM 5.27.2

After updating CiviCRM to the latest version (5.27.2) CiviCRM stopped updating the status of contributions when payment is made using PayPal Standard payment procesor. The payment is processed correctly (money left contributor account and was received by the organisation), however the contribution in CiviCRM is still in Pending status and moreover the confirmation email was not sent to the contributor.

I've read the CiviCRM 5.26 and WordPress Important Notice and I understand that there are some changes in paths, but the page does not provide a clear guide on how to update the PayPal IPN settings. In the past I used just the domain name (https://example.com) for the Notification URL in and it worked without major issues. Now it appears to stooped working. I also tried to update the notification URL in line with the guidelines from Recurring Contributions and Webhooks using the updated path i.e. https://www.example.com/?civiwp=CiviCRM&q=civicrm/payment/ipn/1 but this also does not work.

Is this an issue with Civi/PayPal or am I missing something important?

9
  • I am also at Wordpress 5.4.2 and CiviCRM 5.27.2. I have PayPal Standard, although I recently switched to the PayPal Checkout support available with the Omnipay extension. I can still enable the PayPal Standard payment processor and it seems to be behaving properly, at least for test/sandbox transactions. github.com/eileenmcnaughton/nz.co.fuzion.omnipaymultiprocessor/… – Mark Westergaard Jul 18 '20 at 20:41
  • Do you use Cleaner URLs? docs.civicrm.org/sysadmin/en/latest/install/wordpress/… – Mark Westergaard Jul 18 '20 at 20:52
  • Not really. Do you think I should install the plugin? – Marian Zastawny Jul 19 '20 at 21:36
  • No, I was just trying to assess your implementation in comparison to mine. I do use Cleaner URLs, although I don't think it impacts this issue. I also have just my domain name for the IPN notification URL. Do you see any errors in the CiviCRM Log Viewer? A successful payment confirmation should look something like "PayPalIPN: Received (ContactID: 2; trxn_id: 8A959209KY580015Y)" – Mark Westergaard Jul 20 '20 at 22:49
  • I tried enabling Cleaner URL's, but that does not seem to work either. I tried different settings for IPN including simply specifying the domain, however I still get errors in my log, such as this one: "[debug] $backTrace = #0 {main_dir}/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(432): CRM_Core_Error::backtrace("backTrace", TRUE) #1 {main_dir}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(39): CRM_Core_Error::handleUnhandledException(Object(CRM_Core_Exception))" – Marian Zastawny Jul 22 '20 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.