2

The Activity Details report filter is missing the 'Tags' filter. The last filter is 'Groups' and just before that is 'County' which is where 'Tags' should be. The criteria for this field is 'Is one of' and the selection hint is 'Choose state first' - and is unselectable. The previous criteria to that is also 'County' which is working OK. This is a UK installation, at 5.26.2 and I have another installation at this same level where the 'Tag' filter shows OK. Very odd - I've disabled extensions, checked localisation, settings etc etc. I upgraded to 5.27.3 but exactly the same.

7
  • Maybe a silly question but do you have any tags for activities defined? – Demerit Jul 24 '20 at 19:07
  • Yes, I have tags for activities and No, there are no silly questions! – Andy Clark Jul 24 '20 at 19:09
  • Ahhh. I see that if you have only a tag SET for activities then it doesn't display, as opposed to a bare activity tag (not part of a tag set). – Demerit Jul 24 '20 at 19:12
  • 1
    Well..... I was trying to be tidy and use tag sets. Now I've added the tag as part of the default 'Tag Tree' (which I thought was a set) the tag filter has returned. You have the answer, many thanks! (make this the answer and I'll flag it) Did you spot this from the code in activity.php? – Andy Clark Jul 24 '20 at 19:22
  • Partly an initial guess from experience with tags vs tagsets behaving differently, and was just looking now into the code. Will post answer since I think it's partly in the way the getTags function is used. – Demerit Jul 24 '20 at 19:24
4

Only bare tags (tags not part of an activity set) trigger the field to appear.

The issue seems to be partly how the report retrieves tags where it calls getTags which only returns bare tags unless you give it a parent id for a tag set.

I think the report should be updated to match how it's done elsewhere. Where I've seen it it's usually done as two separate fields.

1
  • 1
    Thanks again, I guess I should raise this as an issue – Andy Clark Jul 24 '20 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.