1

After dealing with a corrupted wordpress site and reinstalling wordpress, i re-enabled the civicrm plugin but did not re-install civicrm.

The backend seems to work fine except that widgets do not work and the Civicrm Page needs to be recreated. I tried to re-save the Civicrm page in the CMS integration admin form. Also tried to run the installer /wp-admin/options-general.php?page=civicrm-install but get a message: You do not have sufficient permissions to access this page.

I suppose I could disable the civicrm plugin, wipe the database, install civicrm and overwrite the database but wondering if there is a more practical solution?

2

I'm not sure if there is a better answer but this is what I resorted to:

  1. Clear Cache
  2. Disable civicrm plugin
  3. Delete /templates_c/ contents
  4. Copy civicrm database to civicrm.sql using mysqldump and delete all tables (or drop / recreate database)
  5. Move /civicrm/civicrm.settings.php tocivicrm.settings.tmp
  6. Enable Civicrm Plugin
  7. Run Civicrm install script http:///wp-admin/options-general.php?page=civicrm-install
  8. Page Civicrm is created and I presume other civicrm install magic in wordpress
  9. Disable civicrm plugin
  10. Replace civicrm.setttings.php with civicrm.settings.tmp
  11. Restore civicrm mysql dump (e.g. mysql civicrmdb < civicrm.sql)
  12. Re-enable civicrm plugin
0

First Delete your civicrm plugin and files folder. Don't keep anything regard to civicrm delete whatever u have.

And then again upload the civicrm plugin into wordpress.

Again create the files folder in plugin folder

enter image description here

Right click the files folder and give permission

  • Thx but my goal is to reinstall an existing civicrm stack that is fully configured. Is that what you are suggesting? – Sonicthoughts Jul 3 '15 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.