2

I have two payment processors that I am using for CiviCRM. Paypal Standard works well. Stripe was working for a while and now I get an error screen saying that Strip.js token was not passed. I have asked the author for help but he says he does not know Joomla. Can anyone shed light on where I should start looking.
Joomla 3.4.2 CiviCRM 4.6.4

Stripe error

  • What precipitated the breakage? Did you upgrade CiviCRM or Joomla or...? – Coleman Jul 3 '15 at 15:56
  • Good question. I was getting this page after I first installed. I made Stripe the default and had Paypal as secondary. Then that broke Paypal, so I put Paypal back as the default. Stripe continued to work for a couple of weeks and then I noticed I stopped receiving payments. I started getting this error regardless if it was the default or not. To be honest, there really wasn't a specific event or update that I can point to that caused this. Joomla 3.4.3 CiviCRM 4.6.4 PHP 5.5.25 – Hudson Essex Terraplane Club Jul 6 '15 at 1:41
2

This seems to be a long-standing issue with the Stripe processor, and from what I can tell (and from what I have experienced), in some cases this extension doesn't play well with other payment processors (including the "pay later" option).

Try disabling Paypal (and Pay Later, if applicable) and then test Stripe again.

See also: https://github.com/drastik/com.drastikbydesign.stripe/issues/76

1

We had similar problems and created a potential fix for it. It is not currently released or merged with the "official" branch as we are still testing. But (if you have a test environment) you could go ahead and try if the fix works for you:

https://github.com/systopia/com.drastikbydesign.stripe

Also, you may be interested in this CiviCRM issue if you want to collect the billing address on a contribution page: https://issues.civicrm.org/jira/browse/CRM-17082

  • I have tried the fix and the one by Matt - on a test site. Problem still exists. Anything I can do to help trouble shoot this? – Dave T Sep 29 '15 at 22:17
0

Dragging up an old thread but I'm now successfully using my dev version of stripe on Joomla: https://github.com/mattwire/com.drastikbydesign.stripe/tree/4.7-mjwconsulting-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.