1

Just upgraded to 5.27.3. Tried to upgrade database, got "Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. Queue runner must be configured before execution."

Any ideas what a "queue runner" is and how I fix it?

Thanks

  • Got the same error on my production site... it works with my development environment on Mac but fails on basically the same wordpress site on my prod environment that runs on Ubuntu... – Serge Aug 3 at 12:18
  • I've just restored the whole site with Updraft, then re-followed the CiviCRM upgrade instructions meticulously... Still getting this Queue runner must be configured before execution error. Clearly something wrong with the latest CiviCRM for Wordpress code. – Peter W Aug 4 at 11:17
1

I saw a solution for this problem on a Drupal platform and decided to try it: you need to delete all the entries in the civicrm_cache table in your Wordpress database using phpmyadmin before you try and upgrade the database. This resolved the issue for me. Civi version 5.27.4

| improve this answer | |
  • I did that, and still get the error... the funny thing is that it worked on my dev environment but not in my production ... however, now it does not work in either... Nothing I read about it worked... clearing the civicrm_cache table did not work either... – Serge Aug 5 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.