1

using WP 5.4.2 - PHP 7.2 - CiviCRM 5.27.3. I have issue with Permalink (I dont know if it is the root cause) but I can create a article using the CiviCRM button to add the CiviCRM event form. On the website, the 1st page form is available and can be filled until the user press the "next" button that display error404 screen on the next page -

3

I expect this is due to changes made to accommodate WP URL changes. If the URL has civiwp in it (and it should) Then I would:

  • make sure that the base page is set - go to https://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fsetting%2Fuf&reset=1

  • Review the Base Page setting and value, it cannot be blank

  • Make sure there is a published page that matches the one in that page

  • If there is no value there, add one, civicrm is the default and then create a WP page with that slug

  • Make sure the page is public and visiuble to all

  • Once you've done that (or confirmed the base page exists) Visit this page https://example.org/wp-admin/options-permalink.php

  • Confirm that your permalinkls are set to anything EXCEPT Plain

  • If it is set to Plain change to one of the other options and save

  • If it is not set to plain, you can exit the page

Then retry the form.

| improve this answer | |
1

Thank you for answering,

=> I cannot use the Permalink but if I create a Post I succesd to pass the 3 step to book the event as public-user

Fab ! Thank you for ths help.

nota : up to now I use http I shall later activate SSL certificate

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.