3

The contribution dashboard on CiviCRM 5.#.# on Drupal 7 is showing that PayPal standard payments are pending but the payment is going through. All PayPal payments are showing as pending including recurring payments. The problem is that when the payment is marked as pending CiviCRM does not send an email to the boss about payment confirmation and contributor details.

When I checked the ConfigAndLog I got:

Jul 28 14:57:02  [warning] CiviCRM thinks site is not SSL, redirecting to {url}
Array
(
    [url] => https://www.***********.org/civicrm/contribute/transact
)


Jul 28 14:57:03  [info] $Fatal Error Details = Array
(
    [message] => We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Then try again. If this error persists, contact the site administrator for assistance.<br /><br />Site Administrators: This error may indicate that users are accessing this page using a domain or URL other than the configured Base URL. EXAMPLE: Base URL is http://example.org, but some users are accessing the page via http://www.example.org or a domain alias like http://myotherexample.org.<br /><br />Error type: Could not find a valid session key.
    [code] =>
)

Jul 28 14:57:03  [info] $backTrace = #0 /public_html/sites/all/modules/civicrm/CRM/Core/Error.php(385): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /public_html/sites/all/modules/civicrm/CRM/Core/Controller.php(833): CRM_Core_Error::fatal("We can't load the requested web page. This page requires cookies to be enable...")

#2 /public_html/sites/all/modules/civicrm/CRM/Core/Controller.php(853): CRM_Core_Controller->invalidKeyCommon()

#3 /public_html/sites/all/modules/civicrm/CRM/Contribute/Form/ContributionBase.php(235): CRM_Core_Controller->invalidKeyRedirect()

#4 /public_html/sites/all/modules/civicrm/CRM/Contribute/Form/Contribution/Main.php(64): CRM_Contribute_Form_ContributionBase->preProcess()

#5 /public_html/sites/all/modules/civicrm/CRM/Core/Form.php(585): CRM_Contribute_Form_Contribution_Main->preProcess()

#6 /public_html/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Display.php(92): CRM_Core_Form->buildForm()

#7 /public_html/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Contribute_Form_Contribution_Main), "display")

#8 /public_html/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Contribute_Form_Contribution_Main), "display")

#9 /public_html/sites/all/modules/civicrm/CRM/Core/Controller.php(351): HTML_QuickForm_Page->handle("display")

#10 /public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(311): CRM_Core_Controller->run((Array:3), NULL)

#11 /public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(85): CRM_Core_Invoke::runItem((Array:15))

#12 /public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))

#13 /public_html/sites/all/modules/civicrm/drupal/civicrm.module(444): CRM_Core_Invoke::invoke((Array:3))

#14 /public_html/includes/menu.inc(527): civicrm_invoke("contribute", "transact")

#15 /public_html/index.php(26): menu_execute_active_handler()

#16 {main}

Jul 29 08:40:09  [debug] PayPalIPN: Could not find an entry for module

Jul 29 08:40:09  [error] ipn_payment_callback_exception
Array
(
    [context] => Array
        (
            [backtrace] => #0 /public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(277): CRM_Core_Payment::handleIPN()

#1 /public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(85): CRM_Core_Invoke::runItem((Array:14))

#2 /public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:4))

#3 /public_html/sites/all/modules/civicrm/drupal/civicrm.module(444): CRM_Core_Invoke::invoke((Array:4))

#4 /public_html/includes/menu.inc(527): civicrm_invoke("payment", "ipn", "5")

#5 /public_html/index.php(26): menu_execute_active_handler()

#6 {main}

        )

)

I then checked the to see on paypal if the IPN url was correct, it was but when I wenbt to it I received the message: Failure: Missing Parameter module.

Then I went and checked the civicrm_system_log and it doesnt show that it is receiving anything from PayPal.

This started about a month ago, we didnt update anything and no dev has touched it,

4
  • What is the form of the IPN URL in PayPal? – guyiac Aug 4 '20 at 18:41
  • I'm not sure what you mean by form. Sorry, still learning. – Ian Love Aug 6 '20 at 16:50
  • What do you have in PayPal listed as the IPN URL? – guyiac Aug 8 '20 at 18:19
  • Did you ever find a solution? – Serge Aug 14 '20 at 13:18
2

You don't say what CiviCRM version you have but this was fixed in 5.27.0 https://lab.civicrm.org/dev/core/-/issues/1608 & sounds similar

This patch - https://github.com/civicrm/civicrm-core/pull/18062 should improve the quality of your error logging

5
  • I'm running 5.27.1 with Wordpress and seeing this same error on membership payments (not recurring payments). – Graham Aug 4 '20 at 8:26
  • Also the linked issue seems to be about Paypal Pro, where the OP and myself are both using Paypal Standard. – Graham Aug 4 '20 at 8:28
  • Updated my 5.27.1 install to 5.27.4 and implemented the patch referred to in this answer. Still not accepting IPNs correctly and now showing nothing in the log. – Graham Aug 5 '20 at 18:34
  • We are using 5.15.1 with Drupal 7. I would love to move to 5.27 but the client is on a shared plan that wont support 5.27. – Ian Love Aug 5 '20 at 19:43
  • If the IPN reaches civicrm it will log it's payload in civicrm_system_log. If the data logged there does not have keys such as 'module' it has possibly been lost through a 301 redirect - changing to a 307 redirect (in apache/nginx config should help) – eileen Aug 6 '20 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.