0

in Mosaico templates the images the images can't be seen. I don't understand why they are uploaded through this link:

GET https://mydomain.com/mosaico/img/?method=placeholder&params=534,200

[HTTP/1.1 401 not found]

I think normally it should be https://mydomain.com/civicrm/mosaico/img/?method=placeholder&params=534,200, but both these url give me "401 not found" and CIVICRM_CLEANURL is enabled.

This is my configuration:

CiviCRM Version: 5.28.0 on Wordpress
Mosaico 2.4.1592820024
Wordpress: 5.5

Thank you for your answers.

1

It turns out this is actually to do with the base page url - it should not have a trailing slash. @massetto knows this I think, because he created the GitHub issue where this is explained so this answer is really for anyone else looking at this later.

From Matt Wire of Veda:

Check your CiviCRM paths/resource URLs and make sure that you are not overriding them if you don't need to.

In CiviCRM make sure that "Wordpress Base Page" is setup as "civicrm" with no "/" - see civicrm/civicrm-core#18332 so this will be fixed in 5.29.

In Wordpress make sure you have a CiviCRM base page (should be at https://yoursite.com/civicrm). Important: Go to Settings -> Permalinks and click "Save Changes".

Now Mosaico images should work and navigating to https://yoursite.com/civicrm/mosaico/img should give a 200 OK and a blank page.

v5.29 is available now, so sounds like upgrading to that should resolve the problem.

| improve this answer | |
0

This is likely to be a permissions error in your wp-content/uploads/civicrm/ext directory. You can probably resolve this by assigning ownership to www-data.

e.g. if your site is installed at /var/www/html then you can fix this with:

chown -R www-data:www-data /var/www/html/wp-content/uploads/civicrm

I've often thought it would be easier if Mosaico stored images in the WordPress image library but presumably this isn't possible with a multi-CMS extension.

| improve this answer | |
  • It doesn't depend on permission. Unfortunately I had not read this Important Notice and the installed version of Wordpress was 5.4. Now I have updated wordpress to 5.5 and the image has this src: https://mydomain.com/mosaico/img/?method=placeholder&params=534,200. I think normally it should be https://mydomain.com/civicrm/mosaico/img/?method=placeholder&params=534,200,but both these url give me "401 not found" and CIVICRM_CLEANURL is enabled. – masetto Aug 15 at 14:38
  • Huh, you're totally right. Now I have the same problem... – Hugh Aug 24 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.