0

I am getting errors about a missing case relationship to reports:

[error] $Fatal Error Details = Array ( [callback] => Array ( [0] => CRM_Core_Error [1] => exceptionHandler )

[code] => -19
[message] => DB Error: no such field
[mode] => 16
[debug_info] => SELECT a.id as `id`, a.name_a_b as `name_a_b`, a.label_a_b as `label_a_b`, a.name_b_a as `name_b_a`, a.label_b_a as `label_b_a`, a.description as `description`, a.contact_type_a as `contact_type_a`, a.contact_type_b as `contact_type_b`, a.contact_sub_type_a as `contact_sub_type_a`, a.contact_sub_type_b as `contact_sub_type_b`, a.is_reserved as `is_reserved`, a.is_active as `is_active`, a_to_civicrm_value_relationship__37.display_block_on_contact_summary as `custom_157`

FROM civicrm_relationship_type a LEFT JOIN civicrm_value_relationship__37 a_to_civicrm_value_relationship__37 ON a_to_civicrm_value_relationship__37.entity_id = a.id [nativecode=1054 ** Unknown column 'a_to_civicrm_value_relationship__37.display_block_on_contact_summary' in 'field list'] [type] => DB_Error [user_info] => SELECT a.id as id, a.name_a_b as name_a_b, a.label_a_b as label_a_b, a.name_b_a as name_b_a, a.label_b_a as label_b_a, a.description as description, a.contact_type_a as contact_type_a, a.contact_type_b as contact_type_b, a.contact_sub_type_a as contact_sub_type_a, a.contact_sub_type_b as contact_sub_type_b, a.is_reserved as is_reserved, a.is_active as is_active, a_to_civicrm_value_relationship__37.display_block_on_contact_summary as custom_157 FROM civicrm_relationship_type a LEFT JOIN civicrm_value_relationship__37 a_to_civicrm_value_relationship__37 ON a_to_civicrm_value_relationship__37.entity_id = a.id [nativecode=1054 ** Unknown column 'a_to_civicrm_value_relationship__37.display_block_on_contact_summary' in 'field list'] [to_string] => [db_error: message="DB Error: no such field" code=-19 mode=callback callback=CRM_Core_Error::exceptionHandler prefix="" info="SELECT a.id as id, a.name_a_b as name_a_b, a.label_a_b as label_a_b, a.name_b_a as name_b_a, a.label_b_a as label_b_a, a.description as description, a.contact_type_a as contact_type_a, a.contact_type_b as contact_type_b, a.contact_sub_type_a as contact_sub_type_a, a.contact_sub_type_b as contact_sub_type_b, a.is_reserved as is_reserved, a.is_active as is_active, a_to_civicrm_value_relationship__37.display_block_on_contact_summary as custom_157 FROM civicrm_relationship_type a LEFT JOIN civicrm_value_relationship__37 a_to_civicrm_value_relationship__37 ON a_to_civicrm_value_relationship__37.entity_id = a.id [nativecode=1054 ** Unknown column 'a_to_civicrm_value_relationship__37.display_block_on_contact_summary' in 'field list']"] )

0

By "report" I assume you mean a CiviReport? It sounds like you used to have a custom field when the report was created and then the custom field was deleted. You can try recreating/resaving the report.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.