2

I'm trying to upgrade CiviCRM on my Wordpress website from 5.25.0 to 5.28.0. I've already completed upgrade in the past, so I know how to do it.

When I try to update the database, upgrade stay stuck on "[Executed: Rebuild Multilingal Schema]", and then become after few minutes "[Executed: undefined]".

  • I try to update to 5.26.0 and it's ok.
  • Then to 5.27.0 and ok too.
  • But with 5.28.0 it's not ok...

I tried to enable debug mod, but it don't give me more details, excepte when I try to update the database again: Update error log

I don't know where else to look, can you help me?

Thanks!

Update 2020-08-19:

I tried to disable all extension, downgrade Wordpress to 5.4.2, and tried to install again 5.28.0 update, but same issue... Here is a video of the progress of the update: https://streamable.com/5fubww

  • I think that particular error is saying you tried to upgrade a second time after the first one failed and now the system is inconsistent. Are you able to restore from backup and try again? One thing that sometimes hurts multilingual during upgrades is advanced logging, at Administer - System Settings - Misc, so if you turn that off before the upgrade that might help. You can turn it back on again after. – Demerit Aug 19 at 0:16
  • @Demerit I restored a backup, disabled logging, tried again to upload version 5.28.0 and update the database, and still the same error. – user3697458 Aug 19 at 2:26
1

I noticed the 5.28.2 update that was just released includes release notes that specify the 5.28.2 update includes a fix for issues that may occur during the upgrade process:

https://github.com/civicrm/civicrm-core/blob/5.28.2/release-notes/5.28.2.md#bugs

Per the release notes, this patch was originally published in 5.27.1. However, it was not initially ported to the concurrent 5.28.beta1.

The 5.28.2 release is now available for download, so it may fix the upgrade issue:

https://civicrm.org/download

Please Note: If CiviCRM was originally installed on your website with version <=4.6, PRIOR TO THE UPGRADE PROCESS for CiviCRM 5.29.0 (next release) you may need to change/update the civicrm.settings.php, Directories, and Resource URLs configuration settings:

https://docs.civicrm.org/sysadmin/en/latest/upgrade/version-specific/#civicrm-5.29

| improve this answer | |
1

Here is the solution, it solved my issue!

https://lab.civicrm.org/dev/wordpress/-/issues/71

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.