0

I try to follow https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/ to upgrade from 5.25 to 5.28.n as 5.25 is broken in WP5.5

After the step Point your web browser to the following URL

http://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1

I consistently get this error despite following the instructions to the letter. I have no extra extensions, on the face of it, this would seem a fairly straightforward process.

#0 /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(337): CRM_Core_Error::backtrace()
#1 /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Page/Upgrade.php(82): CRM_Core_Error::fatal("Your database has already been upgraded to CiviCRM 5.25.0")
#2 /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Page/Upgrade.php(57): CRM_Upgrade_Page_Upgrade->runIntro()
#3 /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(311): CRM_Upgrade_Page_Upgrade->run((Array:2), NULL)
#4 /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(68): CRM_Core_Invoke::runItem((Array:13))
#5 /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(36): CRM_Core_Invoke::_invoke((Array:2))
#6 /home/customer/www/staging21.example.org/public_html/wp-content/plugins/civicrm/civicrm.php(1601): CRM_Core_Invoke::invoke((Array:2))
#7 /home/customer/www/staging21.example.org/public_html/wp-includes/class-wp-hook.php(287): CiviCRM_For_WordPress->invoke("")
#8 /home/customer/www/staging21.example.org/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters("", (Array:1))
#9 /home/customer/www/staging21.example.org/public_html/wp-includes/plugin.php(478): WP_Hook->do_action((Array:1))
#10 /home/customer/www/staging21.example.org/public_html/wp-admin/admin.php(254): do_action("toplevel_page_CiviCRM")
#11 {main}

Warning: Cannot modify header information - headers already sent by (output started at /home/customer/www/example.org/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php:478) in /home/customer/www/staging21.example.org/public_html/wp-admin/admin-header.php on line 9

WordPress 5.5 is available! Please update now.
 Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred.
Your database has already been upgraded to CiviCRM 5.25.0 ```


 Any hints welcome...  I get this with 5.28.0 and 5.28.3 over past couple of days.
  • This might seem a stupid question but have you substituted example.org for the name of your site when running the URL example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/… ? The reason I'm asking is that example.org appears all through your error statement above. – peterb Aug 24 at 14:31
  • Yes - well spotted - Im obfuscating the name of the organisation I am doing this for :-) Only stupid question is the one you didn't ask..... – Southside Aug 24 at 18:50
0

Make sure the civicrm your civicrm plugin is 5.28.x version and you have only single civicrm folder in plugins (no backups, no renamed folders etc)

| improve this answer | |
  • Still getting the same error. I have deleted CiviAdmin and CF CiviCRM plugins. Makes no difference at all... – Southside Aug 24 at 23:17
  • Are you doing this on test site or live? – Pradeep Nayak Aug 25 at 0:28
  • a test site, sir. – Southside Aug 25 at 1:51
  • Can you check uploads/civicrm/civicrm.settings.php file is using correct path for $civicrm_root variable? – Pradeep Nayak Aug 25 at 2:08
  • $civicrm_root = '/home/customer/www/blah.blah/public_html/wp-content/plugins/civicrm/civicrm/'; – Southside Aug 25 at 5:54
0
Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred.

Your database has already been upgraded to CiviCRM 5.25.0

This message indicates that the CiviCRM version installed is 5.25, not 5.28.3 Can you double check that you have replaced all the files in the plugins/civicrm folder? You should make a backup, remove the folder and then extract the new zip file. That way there are no leftover files from prior versions hanging around.

| improve this answer | |
  • I deleted all in plugins/civicrm again and unzipped the 5.28.3 archive. I double checked that I had thre correct version 'code` baseos | u651-sqblahhega2@blah.siteground.eu:/home/customer/www/staging21.blah.blah/public_html/wp-content/plugins/civicrm$ less civicrm.php <?php /* Plugin Name: CiviCRM Description: CiviCRM - Growing and Sustaining Relationships Version: 5.28.3 Requires at least: 4.9 Requires PHP: 7.1 still get the same error sadly – Southside Aug 24 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.