0

I was testing the Record Payment function in the following manner:

  1. Click Contribution under Contact A
  2. Click "Record Contrirbution"
  3. Create Contribution, set Status to "Pending (Pay Later)"
  4. Click "more" for the Contribution record, Select "Record Payment"
  5. Select Payment Method (I chose Cash)
  6. Click Record Payment

This will result in spinning of the logo and nothing happens. This requires a refresh of the page to get out. No payment was recorded to the contribution.

I have checked that this didn't happen to earlier versions (5.12). Any insights? Thanks.

  • can you check civicrm log for more details of the error? – Pradeep Nayak Aug 25 at 8:47
  • Hello Pradeep, I have enabled the dubugging and backtrace to test but there is no new logs entered in the ConfigAndLog. Thanks. – Clement Leong Aug 25 at 9:26
  • Can you open the record payment in a new tab and submit the payment? – Pradeep Nayak Aug 25 at 9:34
  • When I open the record payment in new tab and submit, there is a HTTP 500 error. The URL that failed is xxx.example.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fpayment – Clement Leong Aug 25 at 9:46
  • Can you check php error log? – Pradeep Nayak Aug 25 at 11:05
2

thanks for your guidance, here is the PHP error and it led me to the solution:

Fatal error: Uncaught Error: Call to undefined function bccomp() in
/var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Financial/BAO/Payment.php:374
..

this prompted me to install bcmath:

sudo apt-get update -y 
sudo apt-get install -y php7.2-bcmath 

restarted apache and the problem went away.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.