0

We were still running CiviCRM 5.22.1 when Wordpress updated to version 5.5, which broke our donation pages because of changes how wordpress redirects. I updated to CiviCRM 5.28.3, but the database upgrade fails - all I see is blank dashboard page an empty pair of brackets and a 'retry' link that does nothing.

Does anyone know how to fix this other than perhaps installing a previous version of Wordpress and CiviCRM 5.22.1 on a development server, importing the current CiviCRM database tables, upgrading to CiviCRM 5.28.3, then importing upgraded CiviCRM database tables to the live server?

  • What is set in your CMS integration of CiviCRM? – Pradeep Nayak Aug 27 at 13:29
  • @Pradeep I'm not sure I understand your question unless you mean what CiviCRM components are installed. I was able to update one site on my dev server that was still running wordpress 5.3.4 to CiviCRM 28.3, and the donation pages worked ok after I updated to Wordpress 5.5. When I tried to update to civicrm 28.3 on a second site running wordpress 5.3.4, the database upgrade failed as above. The only difference between the two sites is that the one the won't update uses the CiviContribute component (both site use CiviMail and CiviReport). Plugins and theme are identical. – Don Alejandro Aug 27 at 21:20
3

The problem with updating to version 5.28 was apparently due to some of my civicrm sites having been originally installed with version 4.7. I edited the settings file by comparing to a version 5 setting file. A critical line (~82) was commented out.

Un-commenting that line (and updating other sections of the setting file) allowed me to update all my sites, both live and on the dev server.

Also note that line 82 may be commented out on sites that were originally installed in the early days of CiviCRM 5.x.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.