2

I'm guessing that the upgrade process for CiviCRM under Drupal 8 is something like this:

  1. Use composer require to get the latest version of the package.
  2. Navigate to the database update URL through the browser (http://example.org/civicrm/upgrade?reset=1)

But trying this now, I see what appears to be a version conflict around the pear/log package:

$ composer require --update-with-dependencies civicrm/civicrm-core:5.28.3
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drupal/core-recommended 8.8.8 requires pear/pear_exception v1.0.0 -> satisfiable by pear/pear_exception[v1.0.0].
    - drupal/core-recommended 8.8.8 requires pear/pear_exception v1.0.0 -> satisfiable by pear/pear_exception[v1.0.0].
    - drupal/core-recommended 8.8.8 requires pear/pear_exception v1.0.0 -> satisfiable by pear/pear_exception[v1.0.0].
    - Can only install one of: pear/pear_exception[v1.0.1, v1.0.0].
    - Can only install one of: pear/pear_exception[v1.0.1, v1.0.0].
    - Can only install one of: pear/pear_exception[v1.0.1, v1.0.0].
    - pear/log 1.13.2 requires pear/pear_exception 1.0.1 -> satisfiable by pear/pear_exception[v1.0.1].
    - civicrm/civicrm-core 5.28.3 requires pear/log 1.13.2 -> satisfiable by pear/log[1.13.2].
    - Installation request for civicrm/civicrm-core 5.28.3 -> satisfiable by civicrm/civicrm-core[5.28.3].
    - Installation request for drupal/core-recommended (locked at 8.8.8, required as ^8.8) -> satisfiable by drupal/core-recommended[8.8.8].


Installation failed, reverting ./composer.json to its original content.

How can I get around this problem and upgrade CiviCRM under Drupal 8?

2

You can use:

(confirming this syntax)

karins-MBP:d8civicrm.local sysadmin$ composer require pear/pear_exception:'1.0.1 as 1.0.0'
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 0 installs, 0 updates, 0 removals
Writing lock file
Generating autoload files
  - CiviCRM asset map
30 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Syntax in https://docs.civicrm.org/installation/en/latest/drupal8/ is wrong. Will put in an MR -> https://lab.civicrm.org/documentation/docs/installation/-/merge_requests/10

2
  • KarinG, looks like the correct command is composer require pear/pear_exception:"1.0.1 as 1.0.0" (note colon, quotation marks, and pear/pear_exception instead of pear/exception). Do you think it's worth editing the answer? – TwoMice Aug 31 '20 at 14:33
  • For reference, this worked for me: composer require pear/pear_exception:"1.0.1 as 1.0.0"; composer require --update-with-dependencies civicrm/civicrm-core:5.28.3 civicrm/civicrm-drupal8:5.28.3; cv up:db; – TwoMice Aug 31 '20 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.