1

I'm brand new to CiviCRM and have been asked in stall in a test site and review how it works.

I have the latest WP 5.5 installed. I've uploaded CiviCRM via ftp to the plug ins folder. I went to the installer and I got the error in the screen shot below. Had a look at docs and I updated PHP to 7.2 and same thing happened.

Can anyone tell me if this is common and what fix may be required or is there a doc you could direct me to?

Many thanks, J

THE ERROR: In CiviCRM Database Details

IN RED: Can I create temporary tables in the database? = Could not create a temp table. Can I create lock tables in the database? = Could not create a table in the database. Can I create triggers in the database? = Could not create a database trigger.

IN YELLOW Is the utf8mb4 charac=hter set supported = It is recommended, though not yet required, to configure your MySQL server for utf8mb4 support. You will need the following MySQL server configuration: innodb_large_prefix=true innodb_file_format=barracuda innodb_file_per_table=true

Error

1

Seems like your Civi MySQL database user does not have sufficient privileges attached to it to allow it to install Civi.

This link here should provide you with the information that you need. It is quite old but should get the job done - https://forum.civicrm.org/index.php%3Ftopic=23489.0.html

0

Check your privileges on the database, John. I suspect this may be a MySQL issue.

W

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.