1

After transferring the website to a new URL, I can't get the Civi menu to appear.

I'm running the latest wordpress (5.5.1) and latest Civicrm plugin (5.28.0)

I've also noticed that there are javascript errors showing. These errors are caused by the absolute path being attached to the website path:
https://mysite.com/usr/home/xxxuser/public_html/wp-content/uploads/civicrm/persist/

Not sure if the problem has something to do with the fact that all my URL's are HTTPS?

I have tried updating my $civicrm_setting['URL Preferences']['userFrameworkResourceURL'] in /wp-content/uploads/civicrm/civicrm.settings.php

I've read through various resources and tried many solutions including resetting my paths and clearing my caches 100's of times.

I've tried to install this plugin https://wordpress.org/plugins/civicrm-admin-utilities/ and rebuild the menu. But that didn't help.

The only way I have managed to fix this is by disabling asset caching
https://mysite.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fsetting%2Fdebug&reset=1

Here are some of the resources I have tried:
Civi dashboard and menus won't display after install
https://forum.civicrm.org/index.php%3Ftopic=34290.0.html
Navigation Menu Gone after WordPress Site Transfer
After a CiviCRM update on WordPress the CiviCRM menu has disappeared
Menu bar is missing
Menu bar missing on fresh CiviCRM on Wordpress

I'm at my wits' end with CIVI and I haven't even started using it. If anyone can help, I'd really appreciate it!

  • Updating $civicrm_setting['URL Preferences']['userFrameworkResourceURL'] in /wp-content/uploads/civicrm/civicrm.settings.php should work. Make sure that is after global $civicrm_setting; What are you setting it to? – Aidan Sep 8 at 9:42
  • Thanks Aiden. The userFrameworkResourceURL is set to mysite.com/wp-content/plugins/civicrm/civicrm and it doesn't help. And it is $civicrm_setting is global. – Mark Sep 12 at 17:11
1

check you wordpress directory path in your apache/nginx conf. If its different than '/usr/home/xxxuser/public_html/' either you can change in apache/nginx conf or replace $civicrm_root and template_c path in civicrm.settings.php

Or add below line at the end of the file in civicrm.settings.php

    global $civicrm_paths;
    $civicrm_paths['civicrm.root']['url'] = CIVICRM_UF_BASEURL . 'wp-content/plugin/civicrm/civicrm/';
    $civicrm_paths['civicrm.files']['url'] = CIVICRM_UF_BASEURL . 'wp-content/uploads/civicrm/';

NOTE: make sure you have '/' at the end for CIVICRM_UF_BASEURL value.

| |
  • Genius. Thanks! – Mark Sep 12 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.