0

sorry for what is probably a ridiculous question.

Our wordpress site was migrated to a new server by our host, the domain is unchanged. Now several of the CIVICRM features are not working anymore. Such as payment processing for example or signing up to our newsletter. One of the issues for example is our stripe webhook failing as it now can't reach https://example.org.au/?page=CiviCRM&q=civicrm/payment/ipn/3. When I try to go to the live links for contribution pages, it just shows: "Do not delete this page. Page content is generated by CiviCRM."

I've cleared the cache and reset the paths and looked at the civicrm.settings.php files but couldn't find a place where I had to link to a new IP address. I've also looked for a guide on the CiviCRM page but was unable to find clear instructions on what to do.

If someone can point me in the right direction it would be super appreciated, thank you for the help

cheers, David

  • Please provide more information about signing up for the newsletter. Can the contact load the page on your site (presumably a profile page)? Can they submit the form? Is a contact record created for them? Are they added to the expected group? – BobS Sep 20 at 2:41
  • As soon as you click submit after entering your name and email you are shown a 404 page. No contact is created as well. Also when i try to check the live links for contribution pages I just get shown: "Do not delete this page. Page content is generated by CiviCRM." – user7275 Sep 20 at 6:33
  • It looks like the CIVICRM proportion just isn't working/interacting with the wordpress page. Though I can log into the back end, and also log into the membership dashboard of civicrm through the wordpress page. – user7275 Sep 20 at 6:46
  • which civi version are you on? i think there have been issues with some recent WP versions and you may need to upgrade to latest – petednz - fuzion Sep 20 at 19:23
  • In addition to what Pete said, I'd recommend switching to Clean URLs since page=CiviCRM on the front-end is not supported by WordPress 5.5.x: docs.civicrm.org/installation/en/latest/wordpress/… – Christian Wach Sep 21 at 8:16
0

DNS changes can take up to 48 hours to propagate, and the time can vary widely for each computer trying accessing your site due to the many stages of caching involved. Your payment processor might not have received the new DNS records yet, so wait a day or two. Most/all will retry each payment notification for a number of days/weeks, so you will not lose any information if the card was actually charged.

| improve this answer | |
  • Hi, Sorry. I should have written that the server migration happend a couple weeks ago, so anything to do with delays should have been resolved by nowo. We have suspended payments due to complete Covid-restrictions so didn't notice it until recently but with restrictions supposedly being eased in a few weeks we are in need to resolve this. Also when i try to check the live links for contribution pages I just get shown: "Do not delete this page. Page content is generated by CiviCRM." It looks like some of the interaction between civicrm and the wordpress page is broken. – user7275 Sep 20 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.