0

In CiviCRM > Administer CiviCRM > Display Preferences (/civicrm/admin/setting/preferences/display?reset=1) there's a Configure CKEditor button that does nothing.

CKEditor is stripping out certain style declarations. I want to be able to have simple declaration for adaptive images and the system won't let me.

Any ideas? Thanks in advance for any help...

2
  • Is there any JS error on browser console? Can you go to editor link directly? (civicrm/admin/ckeditor?reset=1) Sep 22 '20 at 14:23
  • Yes! Thank you for the prompt reply - I wasn't expecting that! How can I allow a width: 100% declaration? Thanks in advance!
    – Billyjames
    Sep 22 '20 at 15:49
1

Is there any JS error on browser console? Can you go to editor link directly? (civicrm/admin/ckeditor?reset=1)

1
  • Sorry for taking so long t get back - yes, there's the following error upon clicking the button: Uncaught ReferenceError: config is not defined at crm-ckeditor-default.js?0=362144001600958432&t=K24B:2 (anonymous) @ crm-ckeditor-default.js?0=362144001600958432&t=K24B:2 But using the civicrm/admin/ckeditor?reset=1 link, I am able to get in. But I can't figure out how to stop the editor from stripping tags. I'd switch to TinyMCE, but that doesn't seem to be an option for 5.x. Any ideas? Thanks in advance!
    – Billyjames
    Sep 24 '20 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.