1

Recently in the past we did do a migration from a development site to production and I'm not sure if we were having the issue before migration or not. Every time someone makes a contribution they receive the error:

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Then try again. If this error persists, contact the site administrator for assistance.

Site Administrators: This error may indicate that users are accessing this page using a domain or URL other than the configured Base URL. EXAMPLE: Base URL is http://example.org, but some users are accessing the page via http://www.example.org or a domain alias like http://myotherexample.org.

Error type: Could not find a valid session key.

  • I've checked resource URL's and they appear to be correct.
  • I've scrubbed all trace of the old CMS DB and base dev URL from the civi settings file and replaced them with production
  • The base URL in Civi and WordPress are matching besides a final / that civi has on it's base URL (I tried removing this but made no difference to changed it back
  • I have looked through everything relating to this issue on the stack exchange and have not found anything that worked

If anyone can help me with this I will be forever in your debt.

EDIT: Okay guys after a billion hours of searching, trying things, and changing things I THINK that I have MOSTLY resolved the issue. I THINK what I did to resolve it is .... I realized that it was linking to development CMS DB (they both use same civi DB but different WordPress CMS DB).

After making this change I was able to make contributions in incognito mode and using another browser.... next I tried chrome (the same browser I've been using all along) and got the error. I cleared all cache in chrome, tried again while not logged into WordPress as admin, and it worked.

Next I logged into WordPress as admin and got the error. Deleted my chrome cache and tried again while logged in as admin and got the error.

Then I deleted all cache files in template_c directory and while logged into WordPress as administrator I successfully made a contribution! Then I tried a second time and got the error.

So I think it is working for all new users contributing ... but gives me the error if I'm logged into WordPress as administrator, unless I delete the cache in the template_c directory each time.

Hopefully that makes sense and someone can lead me to the last piece in the puzzle / figure out what is causing this.

  • For this kind of troubleshooting I might try chat.civicrm.org in the wordpress channel and link to your post so they know what you've already tried. – Demerit Sep 24 at 20:24
  • Thank you for this suggestion, I'm gonna go there right now! – MrLucas Sep 24 at 20:50
0

This is an issue documented here: https://lab.civicrm.org/dev/core/-/issues/1997 Fixes have been merged into 5.30 branch https://github.com/civicrm/civicrm-core/pull/18525 and https://github.com/civicrm/civicrm-core/pull/18534

So you can apply the patches, or wait until the 5.30 release in early October.

| improve this answer | |
  • Thank you so much - this was the issue and your reply saved me a billion hours of banging my head against the wall. – MrLucas Sep 24 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.