1

For some reason after updating to CiviCRM 5.29.1 the "Pay Later" option (which is selected) is no longer working on DarrylWPerry.com/donate

EDIT: if I turn off HTTPS/SSL protections it appears.

enter image description here

enter image description here

enter image description here

5
  • we have just had a site report that even though the form is set up for Pay Later, that after selecting a price option the 'pay later' option does not show alongside the other payment options. This was a 5.28.1 site. but could be same issue. will be looking in to it on Monday – petednz - fuzion Sep 26 '20 at 6:54
  • is there an update? – Darryl Perry Sep 28 '20 at 23:02
  • I was wrong. the issue was not that client was not seeing Pay Later. apologies for the mix up. i had only seen the ticket, not actually checked the issue. – petednz - fuzion Sep 29 '20 at 3:44
  • It's definitely a mixed-content issue where all the files in the js folder are being served without ssl. What do you have in admin - system settings - resource urls? Anything that specifically says http? Also check civicrm.settings.php. – Demerit Sep 29 '20 at 21:49
  • 1
    Thanks, civicrm.settings.php still had http instead of https... corrected it, and it works without issue! – Darryl Perry Sep 30 '20 at 23:32
2

The option should appear once you select the amount. If it does than set default one of the option from amounts tab of contribution page

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.