1

It happened after a recent upgrade to 5.27+, using Drupal 8.

2

I notice this: https://github.com/civicrm/civicrm-core/pull/17312 added some nice new callbacks, but since it didn't actually remove the old ones, I suspect this is only affecting Drupal 8 installs that don't have the extern/ directory working.

The key is that these emails are going out with the following at the end of the html:

<img src="https://blackflysolutions.ca/libraries/civicrm/core/extern/open.php?q=12345" width='1' height='1' alt='' border='0'>

In other words - the new callback is not being used when generating the civimail.

After more digging, I found this:

https://github.com/civicrm/org.civicrm.flexmailer/issues/65

Conclusion: update your flexmailer to "master" until there's a new release.

Also: upgrading civicrm to 5.29.1 also fixes it - that release pulls in a new flexmailer.

| improve this answer | |
  • I think you need to do 'something' to switch across though? ie disable, remove the copy from the ext dir & re-enable? We should probably make that easier – eileen Sep 26 at 20:32
  • Well, in theory you could have both paths working, the issue here isn't that the new path doesn't work, it's that it's not being used by flexmailer in it's current release (and the old path doesn't work on Drupal 8 out of the box). If you're not using flexmailer then I'm not sure it would even be an issue. – Alan Dixon Sep 30 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.