1

When I create activities etc. on CiviMobile in my Time Zone I am in it displays as 9 hours later. Currently I am -7 GMT and when setting an activity on the app it automatically changes it to +2 GMT (9 hours ahead of my time zone). When I look on CiviCRM, the activities I created in CiviMobile are 9 hours ahead there too. I’m using the latest CiviMobile on and iPhone. How do I get CiviMobile to use the time/time zone on my phone?

2 Answers 2

2

Jerry, Welcome to CiviCRM stackexchange, your civicrm database stores certain fields with data-type "DATETIME". To improve timezone support, you may want to change these from "DATETIME" to "TIMESTAMP".

For further discussion, please visit https://github.com/civicrm/org.civicrm.doctorwhen

1

This is a workaround, not a solution:
Comment out the time_zone_utc_offset in PublicSettings.php, in Cms.php and in CiviMobileSystem.php

CiviMobile takes the server timezone-settings. Depending on what has been configured there, the result can be misleading...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.