5

I understand from other posts that the new Search Builder is included in 5.29 but is hidden. I'd like to give it a try - how can I access it?

6

Note if you install from a tar file the extension is not available until 5.30. Git/composer/buildkit installs have it in 5.29.

Also the styling on the search page is messy until 5.31, and before then has some other issues.

UPDATE: As of 2020-10-06, it's now visible in the UI as an installable extension called "Search Kit" that comes included with 5.31+. You just install it like any other extension. For earlier than 5.31 see below.


Using user interface

  1. In civi go to the menu for support - developer - api3 explorer.
  2. Choose Extension with action Install.
  3. For parameter pick Extension Key, and for the value put org.civicrm.search.
  4. At the bottom click Execute.
  5. Then the Search menu will have a new option at the bottom.

Using command line

  1. cv api Extension.install keys="org.civicrm.search"
8
  • can this be done using cv?
    – petednz - fuzion
    Sep 30 '20 at 19:14
  • 1
    Is there anything that can't be done with cv? He he - I'll update answer.
    – Demerit
    Sep 30 '20 at 19:18
  • Didn't work for me with 5.29.1 - I got the following: { "is_error": 1, "error_message": "Unknown extension: org.civicrm.search" }
    – Andy Clark
    Sep 30 '20 at 19:19
  • I did it with master. I'm not sure exactly what version it was fully available. You can try it on dmaster.demo.civicrm.org though.
    – Demerit
    Sep 30 '20 at 19:20
  • @AndyClark I tried it with 5.29.1 and it worked ok to install. The theme is off when you visit the search page, and it looks like that's fixed in 5.31.
    – Demerit
    Sep 30 '20 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.