3

On Drupal 7.73 with CiviCRM 5.29.1. Every time the CiviCRM cron runs, I get the following warnings in the Drupal watchdog log. Each is a separate entry.

hook_civicrm_alter_drupal_entities should be updated to pass an array of parameter names to CRM_Utils_Hook::invoke(). Array ( [civi.tag] => deprecated )

hook_civicrm_entity_supported_info should be updated to pass an array of parameter names to CRM_Utils_Hook::invoke(). Array ( [civi.tag] => deprecated )

Any suggestions for how to fix this would be most welcome :-)

Thanks.

1
  • Wow - this totally worked for me ! No more clogged log file. Thank you Eileen.
    – barbaraec
    Oct 6 '20 at 13:31
4

I'm assuming you have the civicrm_entity module installed. There's an open pull request for this at https://github.com/eileenmcnaughton/civicrm_entity/pull/238

If you're able to test out that patch and comment there on that PR it might get merged faster.

1
  • Thank you Demerit. I don't know how to install patches, so I will just wait for the module update whenever it comes. I appreciate your taking the time to let me know. Oct 5 '20 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.