New mailings with all required fields and the default responsive template do not enable the Next or Test mailing buttons. As a workaround I can reuse an old mailing and update the fields. The last successful mailing was sent using 4.6.2, the current installed version of CiviCRM is 4.6.3.

Drupal 7.38

  • 2
    since 4.6.4 is now available you probably want to check if you can replicate your problem on Demo and if not, then upgrade and test again
    – petednz - fuzion
    Jul 7 '15 at 22:51
  • I'll try that, but I didn't see anything related in the issue tracker.
    – Sphinges
    Jul 7 '15 at 22:56
  • 1
    Upgrading to 4.6.6 did not resolve the issue.
    – Sphinges
    Aug 10 '15 at 17:02
  • 1
    So it sounds like civi thinks something is missing hence the Next and Test options are greyed out? Presumably there is nothing obvious eg 'no recipients' message or lack of opt-out tokens etc. Might be worth trying to compare with a 'new mailing' on d46.demo.civicrm.org
    – petednz - fuzion
    Aug 10 '15 at 21:03
  • 1
    The demo works as expected, as soon as I fill in all required fields the buttons are activated; they stay disabled on my site. I'm trying to find the code where the required fields are checked, it might help narrow down the cause if I disable the checks one by one.
    – Sphinges
    Aug 11 '15 at 14:05

Unfortunately, my last post affirming that the problem is real and still present in the current version was deleted because the moderator thought it would be better as a 'comment' without realizing that commenting is disabled for most users. I'm not yet certain of the cause but there are a few fields in the civicrm_mailing table. In particular, the reply_id field (and a few other suspects) look like they may not be getting updated properly. Nicholai, I'd have been happy to post this as a comment if you would be kind enough to enable commenting for individual's with a reputation of less than 50.

  • I can confirm that manually setting the reply_id field in mysql enables the next & test buttons in the mailing.
    – Sphinges
    Nov 10 '15 at 2:58
  • We've stumbled upon the same solution, at about the same time. Now what's the problem???
    – Jeff Wood
    Nov 12 '15 at 17:39
  • As I posted in another place, possibly this will shed some light on the cause: In my case, I had a site where the Auto-responder (from Administer > CiviMail > Headers, Footers, and Automatic Messages) was disabled when the first mailing was created (actually, all of the pre-configured messages/headers/footers were disabled). Enabling all of them and setting as default didn't fix the already created mailing (the "Send Test" and "Next" buttons were still disabled) but everything worked properly in a new mailing, created after enabling pre-configured messages/headers/footers.
    – Kasia W
    Jan 12 '16 at 21:09

I found the solution in another question. Go to Administer > CiviMail > Headers & Footers. Edit the auto-responder, set default to yes. The Next and Test buttons in new mailings should now be enabled.


Since one of the above comments confirms that it works fine on demo instance, I think a possible solution will be to upgrade to latest 4.6.x version. ( if upgrade is possible )


Just found another possible reason whereby no warnings are given. A user has created a template, and created a txt only template too. The footer had unsub in, neither of the above had opt out. I added opt-out to HTML but of course Plain Text was not expanded so i didn't know it was even in use!! And so setting the token in there fixed it. but at no point of the OptOut button being missing from either did i get a warning, until i saved, closed, continued and bingo Plain Text was expanded and showed the warning

I found a couple more situations that the greyed out button can appear which may be less than obvious

  • if there is no Resubscribe Msg set on the Response tab (no alert is currently provided

  • if you put in a Subject, but then decide to switch to using a Template the Subject gets changed to the Subject of the Template, so if the Template does not have one you may get surprised

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.