I'm in the middle of an install and stuck on a couple issues.

I've been all over this StackExchange yet I can't seem to make basic CivicCRM links work in a couple of sections in the site I'm trying to deploy.

  • CiviCRM 5.27.0 running on Wordpress 5.4.2 on top of Ubuntu
  • Yes, my WP permalinks is set to "post name"
  • yes, I have an .htaccess and it looks like this:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
  • yes, Apache is set up to obey that .htaccess for this site

  • yes, my Administer -> System Settings -> CMS Database Integration is set, and it's set to https://crm.[siteiamdeploying].org/civicrm/

  • yes https://crm.[siteiamdeploying].org/civicrm/ is a page that exists and loads

... yet when I do things like:

a) Create an event, flesh out its details and see links like TEST: https://crm.[siteiamdeploying].org/event/register/?reset=1&action=preview&id=98 LIVE: https://crm.[siteiamdeploying].org/civicrm/event/register/?reset=1&id=98

Or, for example, set up a DONATE page and then attempt to load that page by doing

Civicrm-> manage contribution pages -> set up a contribution page ->

... then use that pages "links -> Live page" or "links -> Test page" links to try and load those pages, i.e.


... all I get on those links is the default WordPress "not found" page, i.e.

"Oops! That page can’t be found. It looks like nothing was found at this location. Maybe try a search?"

And I can see these 404'ing/ erroring out in the Apache access logs like this

67.160.XX.XX - - [06/Oct/2020:02:15:54 +0000] "GET /civicrm/contribute/transact/?reset=1&id=4 HTTP/1.1" 404 60939 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0"

Can somebody point me in the right direction and/or towards sensible debug logs or processes before I start throwing heavy things at my monitor?


1 Answer 1


Do you have CMS integration set in your system? You need to have default page or post in WordPress and have it set in CMS integration

  • 1
    @bhance In addition to this, try visiting your "Permalinks" settings page and saving again. This refreshes the WordPress Rewrite Rules. Commented Oct 6, 2020 at 15:05
  • @pradeep yes, my Administer -> System Settings -> CMS Database Integration is set, and it's set to crm.[siteiamdeploying].org/civicrm and that page loads.
    – bhance
    Commented Oct 6, 2020 at 17:25
  • 3
    I think I've solved this. All the documentation I was reading here was saying "Set permalinks to "postname". In Wordpress, I was choosing " Post name crm.[redacted].org/sample-post ..... and not the one below it, saying, "Custom Structure crm.[redacted].org" /%postname%/ -- changing that seems to have made all my pages start loading.
    – bhance
    Commented Oct 6, 2020 at 18:15
  • 1
    maybe add this as your own Answer
    – petednz - fuzion
    Commented Oct 6, 2020 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.