0

I have a Form Processor set up to take newsletter signups on a WordPress.com website. The CiviCRM site is hosted separately.

It was working until recently and I've tried twice to retrace my steps but I've still not got it working.

When I test the Form Processor on the CiviCRM Site, it works as expected (matches to existing contact if present, adds group, adds Data Policy Acceptance Activity, updates one custom field).

I've checked the settings for the Contact Form in WordPress.

When I fill in the form on the WordPress site:

  • It just hangs, and nothing is stored in CiviCRM
  • The debug file says

[10-Oct-2020 12:59:14 UTC] PHP Notice: Undefined offset: 1 in /srv/htdocs/wp-content/plugins/contact-form-7-civicrm-integration/contact-form-7-civi.php on line 59

This is lines 57-63 in the file mentioned:

  foreach($parameters as $param) {
    list($key, $val) = explode("=", $param);
    if (!empty($key)) {
      $data[$key] = $val;
    }
  }

Any ideas what I need to change/what I've missed?

0

If $param doesn't have an = in it then the list() wouldn't have an offset 1 element. Can you debug $param?

2
  • Maybe I'm missing something but the debugger in the browser shows up nothing, as though no action has been triggered. Where should I be looking to debug the $param? (I'm not a frequent php coder) – Rose Lanigan Oct 12 '20 at 13:55
  • The browser wouldn't show much. You could do something like put CRM_Core_Error::debug_log_message(var_export($param, true)); just after the foreach in the php file, and then look in ConfigAndLog. – Demerit Oct 12 '20 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.