2

I am able to send group emails from a search (less than 50), am able to send a test email from the Administer / System Settings / Outbound Email, but when I try to do a CiviMail test, I get Error in call to Mailing_send_test : mail() returned failure.

What should I look for?

I'm running CiviCRM 4.6.4 with Drupal 7.3.8 and here's the contents of the ConfigAndLog file after trying to send mail with the Debug and Backtrace on

    Jul 09 08:29:28  [info] $backTrace = #0 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Core/Error.php(894): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 [internal function](): CRM_Core_Error::exceptionHandler(Object(PEAR_Error))
#2 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/packages/PEAR.php(931): call_user_func((Array:2), Object(PEAR_Error))
#3 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/packages/PEAR.php(566): PEAR_Error->PEAR_Error("mail() returned failure", NULL, 16, (Array:2), NULL)
#4 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/packages/Mail/mail.php(175): PEAR->raiseError("mail() returned failure")
#5 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Mailing/BAO/MailingJob.php(707): Mail_mail->send("\"Mr. Matt Burkhardt\" <mlb@imparisystems.com>", (Array:11), "--=_fd576d140be170d71ee812779cea380f\nContent-Transfer-Encoding: 8bit\nConten...", "26")
#6 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Mailing/BAO/MailingJob.php(611): CRM_Mailing_BAO_MailingJob->deliverGroup((Array:1), Object(CRM_Mailing_BAO_Mailing), Object(Mail_mail), "", (Array:0))
#7 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Mailing/BAO/MailingJob.php(198): CRM_Mailing_BAO_MailingJob->deliver(Object(Mail_mail), (Array:12))
#8 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/api/v3/Mailing.php(643): CRM_Mailing_BAO_MailingJob::runJobs((Array:12))
#9 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/Civi/API/Provider/MagicFunctionProvider.php(89): civicrm_api3_mailing_send_test((Array:10))
#10 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/Civi/API/Kernel.php(96): Civi\API\Provider\MagicFunctionProvider->invoke((Array:9))
#11 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/api/api.php(23): Civi\API\Kernel->run("mailing", "send_test", (Array:10), NULL)
#12 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/Civi/API/Subscriber/ChainSubscriber.php(195): civicrm_api("mailing", "send_test", (Array:10))
#13 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/Civi/API/Subscriber/ChainSubscriber.php(72): Civi\API\Subscriber\ChainSubscriber->callNestedApi((Array:34), (Array:5), "create", "Mailing", 3)
#14 [internal function](): Civi\API\Subscriber\ChainSubscriber->onApiRespond(Object(Civi\API\Event\RespondEvent))
#15 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(164): call_user_func((Array:2), Object(Civi\API\Event\RespondEvent))
#16 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(53): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch((Array:4), "api.respond", Object(Civi\API\Event\RespondEvent))
#17 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/Civi/API/Kernel.php(221): Symfony\Component\EventDispatcher\EventDispatcher->dispatch("api.respond", Object(Civi\API\Event\RespondEvent))
#18 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/Civi/API/Kernel.php(98): Civi\API\Kernel->respond(Object(Civi\API\Provider\MagicFunctionProvider), (Array:9), (Array:5))
#19 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/api/api.php(23): Civi\API\Kernel->run("Mailing", "create", (Array:34), NULL)
#20 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Utils/REST.php(404): civicrm_api("Mailing", "create", (Array:34))
#21 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Utils/REST.php(640): CRM_Utils_REST::process((Array:3), (Array:32))
#22 [internal function](): CRM_Utils_REST::ajax()
#23 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Core/Invoke.php(278): call_user_func((Array:2))
#24 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:12))
#25 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#26 /home6/frederk3/public_html/lcfcadmin/sites/all/modules/civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:3))
#27 [internal function](): civicrm_invoke("ajax", "rest")
#28 /home6/frederk3/public_html/lcfcadmin/includes/menu.inc(519): call_user_func_array("civicrm_invoke", (Array:2))
#29 /home6/frederk3/public_html/lcfcadmin/index.php(21): menu_execute_active_handler()
#30 {main}
  • Please post a debug/backtrace? You can turn on debugging/backtrace from Administer menu > System Settings > Debugging and Error Handling. Where are you seeing this message? In the scheduled job log? Also, please post CiviCRM version number and CMS. – Jon G - Megaphone Tech Jul 8 '15 at 4:33
  • I am running CiviCRM 4.6.4 on Drupal 7.3.8. It has been upgraded several times, but the last upgrade was from 4.2. This is the first that I've tried to implement CiviMail, but I have used mail from the Search results before. – Mattie Jul 9 '15 at 12:44
  • Are any of the groups smart groups? We were experiencing a similar issue regarding a "corrupt" smart group. See civicrm.stackexchange.com/questions/489/… – pmoz Jul 9 '15 at 12:56
  • No. I'm trying to send it to one group that consists of three users. – Mattie Jul 17 '15 at 19:42
1

It is likely a problem of configuration of your server. If you have a cheap hosting, they might have disabled the mail() function. If it's your own server, you need to install a mail server for instance postfix.

A workaround might be to try using smtp instead of mail, with localhost as the mail server. if this doesn't work, you might want to try the sendmail option.

Might be worthwhile checking with your host provider, see if they impose restrictions on mailing from php. If they do and don't want to change their policy, your only option might be to move to a less restrictive host

0

I have the same problem. I create a mailing, I use "send test mail" and I get this error : Error in call to Mailing_send_test : mail() returned failure

Any idea ? Regards, HashKey

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.