1

I am about to run the CiviCRM installer, but I get the following warning:

CiviCRM MySQL utf8mb4 Support: It is recommended, though not yet required, to configure your MySQL server for utf8mb4 support. You will need the following MySQL server configuration: innodb_large_prefix=true innodb_file_format=barracuda innodb_file_per_table=true

However, my database configurations are already as follows: enter image description here

So what exactly is "MySQL utf8mb4 Support" and what are the steps to configure it properly? (e.g. what do I do with this exactly? "innodb_large_prefix=true innodb_file_format=barracuda innodb_file_per_table=true")

2

You need to put those in your mysql configuration file (e.g. sometimes located at /etc/my.ini, depends on your host) as described at https://docs.civicrm.org/installation/en/latest/general/requirements/#mysql-configuration

[mysqld]
innodb_large_prefix=true
innodb_file_format=barracuda
innodb_file_per_table=true

If you don't have access to that you'll need to ask your hosting company.

At the time of writing (civi v5.30), all this does is make it possible to use utf8mb4, but civi will still install as utf8. After install, you can manually convert by choosing the menu option Support - Developer - Api explorer v3, and choosing Entity: System and Action: utf8conversion and then clicking the Execute button.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.