2

hope you're well. New user of the MailChimp integration extension available here: https://civicrm.org/extensions/mailchimp-civicrm-integration

We are attempting to integrate CiviCRM 5.29.0 on Wordpress and MailChimp, but we get this error when we perform the test sync (see image). As you can see (despite blurring out the info) it is able to pull MailChimp information but errors out with the 2nd error below it.

enter image description here

I found this page here that suggested the problem might be a lack of a Anonymous User user with webhook permissions in CiviCRM but couldn't find anything about explicitly adding webhook permissions to a role. Struggled to find in this page what exactly I need to permit in order to grant the right permissions. How to make the callback URL from Mailchimp accessible from anonymous users in Wordpress?

Could someone point me in the right direction for a guide on how to set up CiviCRM 5.29.0 for this MailChimp integration?

Thanks everyone :)

  • Here is the documentation about setting permissions in CiviCRM: docs.civicrm.org/user/en/latest/initial-set-up/… – William Mortada Oct 17 at 17:37
  • Hi William, thanks for your message. I've checked that documentation and found the page I was missing previously. It hasn't helped however. I've added the permission specifically to Anonymous User to send webhook posts and to all user roles after that, neither has fixed the problem. There's a WP couple users that CiviCRM has to work with here - one in Anonymous Role and one in Administrator role. It should have enough roles available to test with, considering the docs specifically say "any user role must have webhook permission". Do you know what the next step to test would be? Thanks – Ash Oct 19 at 6:14
  • I don't have experience of using that particular extension so can't advise any further, but I spotted this which may be relevant: github.com/veda-consulting-company/… – William Mortada Oct 19 at 16:37
  • Also, I note that there are several MailChimp extensions. It might be worth checking out this one that was released recently: lab.civicrm.org/extensions/mailchimpsync – William Mortada Oct 19 at 16:40
1

Check the CiviCRM WordPress Permissions page, you need to enable Anonymous Role the permission to execute the Mailchimp Webhooks.

| improve this answer | |
  • Is this the CiviCRM access control page or WordPress user page? I've checked both and can't see reference to adding webhook permissions. For CiviCRM I added all permissions to both Admins and a new Anonymous role, that didn't change anything. If you're talking about WordPress, the Anonymous User has all additional permissions corresponding to CiviCRM. Is it a core permission by chance? I didn't see anything there about webhook permissions. With all CiviCRM permissions, it has the same problem. – Ash Oct 15 at 9:04
  • Be careful not to give too many permissions to the anonymous user role as this could be a security risk. – William Mortada Oct 17 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.