0

For upgrading CiviCRM, I've been told that it is safer to upgrade with drush than manually, but my version of drush, according to another post, has to be upgraded from 8.0.0 to 8.4.5. (See Command "drush vset maintenance_mode 1" gives me an error)

After looking a bit around how to do it when your current version has been installed with composer, I discovered I had to issue the command:

composer require drush/drush:8.4.5

I did it, but I got next output, and I don't know how to deal with that:

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drush/drush 8.4.5 conflicts with chi-teck/drupal-code-generator[1.33.0].
    - drush/drush 8.4.5 conflicts with chi-teck/drupal-code-generator[1.33.0].
    - drush/drush 8.4.5 conflicts with chi-teck/drupal-code-generator[1.33.0].
    - Installation request for drush/drush 8.4.5 -> satisfiable by drush/drush[8.4.5].
    - Installation request for chi-teck/drupal-code-generator (locked at 1.33.0) -> satisfiable by chi-teck/drupal-code-generator[1.33.0].


Installation failed, reverting ./composer.json to its original content.

Any help would be appreciated because I have no clue on what drupal-code-generator has to do or to be. Probably, I have to update drupal for being able to update drush, but I need drush to update drupal: so I am trapped into a deadly embrace.

Current version of CiviCRM: 5.26.0 (could be updated to 5.30.0)

Current version of Drupal: 7.69 (needs to be updated to 7.73)

Current version of PHP: 7.4.3 (OK)

4
  • 1
    I'm a little confused. Either your drupal 7 site was originally installed from tarball, from drush, or from composer. If drupal itself was installed with composer, then you would update drupal with composer and drush is just extra. If it was installed from drush, then your drush would be somewhere else outside the drupal folder tree and shouldn't be getting hung up on other dependencies. So I'm not sure which this is. – Demerit Oct 22 '20 at 18:10
  • @Demerit: I first installed drupal 7 from a tarball. I didn't know that drush had to be installed in the same way, so I installed it with composer. I am ready to remove the composer installation of drush and to reinstall it with a tarball. The problem is that the docs are very unclear. Your advice seem to be the best I found up to now, so I will go on following it. – Pierre François Oct 22 '20 at 19:29
  • 1
    The docs provide too many options I agree. You could also just update drupal manually and forget about drush unless you plan to use it for other things. Download from drupal.org/project/drupal/releases/7.73 and detailed instructions at drupal.org/docs/7/update/core-option-2 – Demerit Oct 22 '20 at 19:37
  • While CiviCRM probably works fine on PHP 7.4, there's been some trouble getting it to pass the testing suite. Out of caution, I'd advise against running it in production. Also Drupal 7 is already incompatible with PHP 7.4 until you upgrade. – Jon G - Megaphone Tech Oct 23 '20 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.