0

I have a site I manage that uses a "Multi-Select" HTML field type. I do not use the field so I cannot say exactly how recently but no more than the last month our field stopped being able to be edited or shown in search forms.

If I switch to checkboxes it works perfectly. If I switch back Multi-Select I get the same problem and when I save I get the error, "Please enter valid - Data and Input Field Type."

It is like it is trying to use the pre-CiviCRM 4.5 form element. I do not know how that could be.

I am running CiviCRM 5.28.2 in Drupal 7.

Any help is greatly appreciated.

Thanks, Josh

2
  • it can sometimes help others help you if you can try replicating the problem on one of the demo sites eg dmaster.demo.civicrm.org which may either make it clear that it is not a current problem, or that it is and needs a fix. it won't help though if this is an issue where something old has broken with newer updates but regressions need finding and fixing too – petednz - fuzion Nov 12 '20 at 3:51
  • I could not recreate this. I have no idea. – Josh Nov 22 '20 at 19:14
1

I could not recreate this. The most simple solution was to make a new field and then import the old data into the new field.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.