I am on civi v5.25 with Wordpress v5.5.3. After adding manual off-line contributions (no credit card) each with a different financial type to a contact, none of the amounts display on the contact's contributions. I also recorded additional payments on a couple of the contributions, and still no amounts display. The contribution detail report does not show the amounts, only the number of contributions, and oddly it also shows the number of contributions beside the amount, as in: Amount $ (3). Similar result on the contribution summary report. I've reviewed the financial account and type config and cannot see anything obviously wrong. I am new to civi so this could be something simple. Thanks.enter image description hereenter image description here

Contribution Dashboard, Contribution from Dashboard and Summary Report

enter image description here

  • In Civi go to Support > Developer > API Explorer 4 In Entity select Contribution > In Action select Get > In Where select Contact ID then in the blank box after the = start typing the name of the contact and then select one that comes up. At the upper right click Execute. In the bottom right you will see the results of contributions for that contact. In the array look to see if Total Amount has a number. This is where I would start troubleshooting, we can take next steps after this. – Iowa Boy Nov 28 '20 at 17:34
  • Also, please add more details. Is this a new setup or has everything been working until you did a manual entry? Was this the first time doing a manual entry? Is this only for one contact or did it happen for several. – Iowa Boy Nov 28 '20 at 17:39
  • Welcome Rose (i deleted my comment after rereading your issue) – petednz - fuzion Nov 29 '20 at 22:24
  • Thanks Iowa Boy. I followed your steps for troubleshooting and I can see numeric values with total_amount variable. This is true for other contacts where I add a manual contribution. This is a new installation and I am just testing it now. I do see aggregate amounts on the Contribution Dashboard graphs, the Recent Contribution Contacts are listed below the graphs, but with no figures in the Amount column. Thanks. – Rose Nov 30 '20 at 21:47
  • When running a Contribution Report, check your filer criteria. About #17 down on the Filter tab is "Contributions or Soft Credits". Do you have that on Contributions? Also, what do you have for Sort and Grouping Tabs? I would start with None for both. – Iowa Boy Dec 1 '20 at 16:08

As we were upgrading our civi software we learned that removing the values in the Monetary Value Display fixed the problem. It looks like petednz-fuzion was pointing me in the correct direction. After the software upgrade, the value shown in his screenshot below for Monetary Value Display (%!i) were automatically populated into my config, and this also worked. Thanks for your help!

  • oh good to know it was helpful. you should accept your own answer if you can to help close this off – petednz - fuzion Jan 12 at 21:35

This is not an Answer so i accept it will be down voted but can't add screenshots to a Comment.

Can you confirm if anyone has tweaked the settings at civicrm/admin/setting/localization?reset=1 in a way that may have messed up the currency/value?

enter image description here

  • Thanks Pete. I do not think so. I checked those again and we accept CAD ($) and the Monetary Display settings look correct: Amount = %c %a, and Value = %c in my. – Rose Nov 30 '20 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.