0

We're just a very small charity trying to put this together with limited experience.

I had set up some custom fields for the database but some changes to those fields was requested which I made and now when I run a find contact search, a list of releveant contacts will come up but if I click on a contact name I get this message:

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: no such field

I imagine it has something to do with changing the fields. Any ideas of how to move forward with this? I only had uploaded some of our database as a test so happy to delete all of our contacts and start again but don't know how.

Thanks in advance!!

9
  • Sounds like the fields have caused the issue. First thing to check is if you changed the search results profiles to include those fields. If you did then that would probably explain why you're seeing the message. If not then pasting in the content of the CiviCRM Log file for the error will help point to which field is causing the issue. – Parvez Saleh Dec 1 '20 at 10:20
  • might help if you give an example of a change you made to one of the fields – petednz - fuzion Dec 1 '20 at 18:20
  • @petednz-fuzion thanks for the prompt, for example I have changed the field set a field is in although theis can be done using the move function so I figured that shouldn't cause an issue. – Clair Dec 1 '20 at 23:07
  • @petednz-fuzion I also made changes such as changing the options in a multiple choice custom field and chaning the name of custom fields. Thks. – Clair Dec 1 '20 at 23:10
  • UPDATE tried to add a new contact and got the same 'DB error:no such field' with this line beneath 'Fatal error: Uncaught CRM_Core_Exception: [0: Transaction integrity error: Expected to find active frame thrown in /home/adhdrich/www/www/wp-content/plugins/civicrm/civicrm/Civi/Core/Transaction/Manager.php on line 93' – Clair Dec 1 '20 at 23:40
0

Try installing the CiviCRM Log Viewer extension (you can do that via the web interface) and then you'll be able to see more details about the specifics of the error, which are logged in a CiviCRM error log file that is otherwise not easy to access.

The 'Transaction integrity error' isn't super useful, it's evidence of a deeper issue - see: https://civicrm.stackexchange.com/search?q=Transaction+integrity+error%3A+Expected+to+find+active+frame

That deeper issue would be more easily seen via the error log.

Sometimes, if you make changes to custom fields via the web interface, it will only half-complete, leaving a mismatch between the tables in mysql and what CiviCRM thinks is there. That might be evidence of a server setup issue, for example.

The easiest solution, if it works, is to delete the fields that make up the custom fieldset, then delete the fieldset itself and start again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.