2

So I've downloaded the file to update to civiCRM 5.32.2 and I'm on WordPress 5.6. When I upload the file to the plugins page it tells me that I need to overwrite the other version. Cool no problem. When I tell it to do that it tries for a few minutes and then it gives me a 503 error.

Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

If I then try to activate the new version of civiCRM the whole site crashes with a fatal error that says the following.

Warning: include_once(/home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/includes/civicrm.users.php): failed to open stream: No such file or directory in /home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/civicrm.php on line 623

Warning: include_once(): Failed opening '/home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/includes/civicrm.users.php' for inclusion (include_path='.:/opt/alt/php74/usr/share/pear') in /home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/civicrm.php on line 623

Fatal error: Uncaught Error: Class 'CiviCRM_For_WordPress_Users' not found in /home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/civicrm.php:624 Stack trace: #0 /home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/civicrm.php(379): CiviCRM_For_WordPress->include_files() #1 /home/enaosj1vvfz0/public_html/wp-includes/class-wp-hook.php(287): CiviCRM_For_WordPress->setup_instance('') #2 /home/enaosj1vvfz0/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #3 /home/enaosj1vvfz0/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #4 /home/enaosj1vvfz0/public_html/wp-settings.php(420): do_action('plugins_loaded') #5 /home/enaosj1vvfz0/public_html/wp-config.php(89): require_once('/home/enaosj1vv...') #6 /home/enaosj1vvfz0/public_html/wp-load.php(37): require_once('/home/enaosj1vv...') #7 /home/enaosj1vvfz0/public_html/wp-admin/admin.php(34): require_once('/home/enaosj1vv...') #8 /home/enaosj1vvfz0/public_html/wp-admin/plugins.php(10): require_once('/home/enaosj1vv...') # in /home/enaosj1vvfz0/public_html/wp-content/plugins/civicrm/civicrm.php on line 624 There has been a critical error on this website. Please check your site admin email inbox for instructions.

Learn more about debugging in WordPress.

I have all of my other plugins deactivated so I know it's not a conflict there. I've tried using multiple themes so no conflict there. I've even addressed caching issues as described in another thread (Errors involving /wp-content/plugins/civicrm/civicrm/CRM/Extension/ClassLoader.php)

The only other suggestion my hosting company had was to unzip the file myself and replace the files manually which just seems like a good way to screw up my data.

1
1

You can't use the WordPress plugin update system. You must do it via either ftp or SSH. You will find the full documentation at https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/

While complete and accurate, the comprehensiveness of that doc can be a little overwhelming. I created a checklist for myself to cover the bases on my server. It may be helpful to you. You can see my CiviCRM upgrade on WordPress summary here: https://kapn.net/support/civicrm-upgrade/

Some bits are very specific to me but they should be obvious. If it looks like gobbledygook to you then ignore it and focus on the official docs above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.