1

I'm running CiviCRM in Wordpress 5.6

I tried upgrading from CiviCRM 5.21 to 5.32 following this process: https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/

Now, the last step is visiting the update page, but there I get this error message:

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred.
DB Error: unknown error
 Fehlerbeschreibung
Datenbank-Errorcode: You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable), 1419
Zusätzliche Details:
Array
(
    [callback] => Array
        (
            [0] => CRM_Core_Error
            [1] => handle
        )

    [code] => -1
    [message] => DB Error: unknown error
    [mode] => 16
    [debug_info] => CREATE TRIGGER civicrm_domain_trigger BEFORE INSERT ON civicrm_domain FOR EACH ROW BEGIN END [nativecode=1419 ** You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)]
    [type] => DB_Error
    [user_info] => CREATE TRIGGER civicrm_domain_trigger BEFORE INSERT ON civicrm_domain FOR EACH ROW BEGIN END [nativecode=1419 ** You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)]
    [to_string] => [db_error: message="DB Error: unknown error" code=-1 mode=callback callback=CRM_Core_Error::handle prefix="" info="CREATE TRIGGER civicrm_domain_trigger BEFORE INSERT ON civicrm_domain FOR EACH ROW BEGIN END [nativecode=1419 ** You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)]"]
)

What could I do next? System Status says

Database Upgrade Required
New codebase version detected. You must visit upgrade screen to upgrade the database.

thanks, geb

2

Mysql has a feature called binary logging. You have it turned on, so either:

(a) turn it off, OR

(b) the mysql user needs to have the SUPER privilege, OR

(c) you need to set the mysql configuration variable log_bin_trust_function_creators.

See https://docs.civicrm.org/installation/en/latest/general/requirements/#binary-logging

You may need to ask your hosting provider what they will allow.

2
  • 1
    Thanks for the reply! The administrator set the log_bin_trust_function_creators variable and granted me SUPER privilege. He also says that binary logging was turned off already. When I go to the CiviCRM upgrade screen now, I still get exactly the same error message as before. Is there a different step I could try?
    – gebseng
    Jan 12 at 11:28
  • Just want to link it to this also: dba.stackexchange.com/questions/269083/…
    – salah-1
    Nov 17 at 19:03
2

The administrator disabled gssapi on the server, after that the update went smoothly, I have no idea why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.