CiviCRM 5.32.2

Joomla! 3.9.23

Mysql 5.7.23

PHP 7.3.24

PHP Extensions installed

  • PHP BCMath
  • PHP Curl
  • PHP Multibyte
  • PHP Zip

PHP Configuration

- Set memory_limit to 512mb - safemode PHP directives are off. - MAMP XCache - This is off.

I kick off the install and after about 5 to 10 min the system kicks the following error:

  • [error] mod_fcgid: read data timeout in 360 seconds

Any ideas on how to fix this?

  • Welcome to SE! What errors are showing in your logfiles?
    – Aidan
    Dec 23, 2020 at 16:18
  • [Tue Dec 22 00:44:48 2020] [error] mod_fcgid: read data timeout in 360 seconds [Tue Dec 22 00:59:48 2020] [error] mod_fcgid: read data timeout in 360 seconds [Tue Dec 22 01:51:59 2020] [error] mod_fcgid: read data timeout in 360 seconds Dec 28, 2020 at 17:10
  • Web Host will not increase the mod_fcgid time. Dec 28, 2020 at 17:11

2 Answers 2


The timeout issue itself is caused by a new issue that is created in the latest joomla version itself (3.9.23). Joomla version 3.9.23 introduced an issue: unzipping an install file with several zips inside itself won't work. This causes the behavior you describe. In the next version this issue will be solved. You can solve the issue now by manually installing a patch made by Yootheme, which can be found here: https://yootheme.com/support/question/142357


To solve the timeout issue, I unzipped the archive in the admin folder then in the configure.php put a block comment from line 39 to line 59. Install was done in record time.

Steps taken

  1. File Transfer
  • On your server, create a folder in your Joomla instance under administrator/components called com_civicrm.
  • On your computer unzip your Joomla install package (CiviCRM-5.32.2-Joomla). go to CiviCRM-5.32.2-joomla\com_civicrm\admin
  • On your server copy all the files and folders in this directory to your Joomla instance under administrator/components/com_civicrm.
  • Unzip the civicrm.zip and it should create a fold called civiCRM under the com_civicrm folder.
  1. Configuration Scripting
  • Edit the configure.php in the administrator/components/com_civicrm folder on your server.
  • Block comment (/* at line 39 and */ at line 59) the unzip block of the script.
  1. Run the Joomla install.

This is what worked for me and the install was much faster.

  • Latest Joomla! update (v 3.9.24) has resolved this problem and the workaround is no longer required. Jan 14, 2021 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.