1

I am having trouble installing CIVICRM on my Joomla powered domain.
Here is my environment: System Information

  • PHP Built On: Linux a2plcpnl0712.prod.iad2.secureserver.net 2.6.32-954.3.5.lve1.4.80.el6.x86_64 #1 SMP Thu Sep 24 01:42:00 EDT 2020 x86_64
  • Database Type: mysql Database Version: 5.6.49-cll-lve
  • Database Collation: latin1_swedish_ci Database Connection
  • Collation: utf8mb4_general_ci
  • PHP Version: 7.4.11
  • Web Server: Apache
  • WebServer to PHP Interface: litespeed
  • Joomla! Version: Joomla! 3.9.23 Stable [ Amani ] 24-November-2020 15:00 GMT
  • Joomla! Platform Version: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36

I tied installing the civicrm-5.32.2-joomla-alt.zip and the civicrm-5.32.2-joomla.zip builds, but after a while I receive the following:

"Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Unavailable error was encountered while trying to use an ErrorDocument to handle the request."

In file manager, the folders ~/administrators/components/com_civicrm/ and ~/components/com_civicrm and their subfolders are present. the folder ~/media/civicrm is not present. The database does not show any Civicrm tables.

Any ideas on what I may be doing wrong? Thank you in advance.


Thank you all for the answers. I have set up my test local environment with a new install of joomla 3.9.22 and was successful in installing Civicrm.

On the production environment, I downgraded to php 7.3 and applied the suggested patch to the joomla 3.9.23. After proceeding with the installation of civicrm, I am getting a different error message:

An error has occurred. 0 undefined extension class 'Smarty_Internal_Method_Assign_By_Ref'

Does anyone know what went wrong and how to solve the issue?

2
  • Welcome to SE! php 7.4 is not fully supported - switch to 7.3 Sounds like you have the files in place but the installation has failed if you have no db tables. Do the log files show errors from the installation process?
    – Aidan
    Dec 23 '20 at 16:16
  • I'm having the same issue on Joomla 3.9.23. Succeeded on Joomla 3.9.22 in our test environment so I suspect it's something about CiviCRM and Joomla 3.9.23. (Our test and prod environment are otherwise identical, incl. PHP, MySQL versions, etc.)
    – MtnPavlas
    Jan 2 at 18:02
2

Joomla version 3.9.23 introduced an issue: unzipping an install file with several zips inside itself won't work. This causes the behavior you describe. In the next version this issue will be solved. You solve the issue now by manually installing a patch made by Yootheme, which can be found here: https://yootheme.com/support/question/142357

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.