0

I am attempting to turn on detailed logging for a site (Administer -> System Settings -> Misc (Undelete, PDFs, Limits, Logging, Captcha, etc.), the Logging option. When I save the change, I'm getting a gateway timeout, and am working with the hosting company to resolve that.

In the meantime, where is that setting saved? I don't see a place in civicrm.settings.php nor in the civicrm_setting table. But I suspect that's because No is the default.

How and where can I add that setting manually? So far, my Google Fu is failing me.

Thanks!

1

It's in civicrm_setting but if it's never been turned on it won't be there. But also it's more than just a setting - you would need to rebuild the schema and triggers.

If you have cv installed you can do cv ev "Civi::settings()->set('logging', 1); $s = new CRM_Logging_Schema(); $s->enableLogging();" to do it from the command line manually.

2
  • Thanks! I don't have cv installed. Is there anywhere that details the civicrm_settings record that is needed? But really, sounds like I need to work through the gateway timeout issue. – RiverRunner Jan 3 at 3:41
  • I could tell you what the database row looks like, but inserting it by itself will just make your database inconsistent. The extra tables and triggers need to get created in order for logging to be enabled and do anything. – Demerit Jan 3 at 4:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.